Skip to content
OpenAdvisories

Weakness (CWE)

CWE-636: Not Failing Securely

Class Draft

When the product encounters an error condition or failure, its design requires it to fall back to a state that is less secure than other options that are available, such as selecting the weakest encryption algorithm or using the most permissive access control restrictions.

How to prevent it (1 mitigation)
  1. Architecture and Design

    Subdivide and allocate resources and components so that a failure in one part does not affect the entire product.

Source: MITRE CWE-636

30 results · Clear filters · Feed

  • High 8.1

    Directus before 12.1.0 Authorization Bypass via Public WebSocket REST Interface

    Directus before 12.1.0 contains an authorization bypass vulnerability that allows unauthenticated attackers to skip permission checks by sending a failed auth message on public-mode WebSocket connections. Attackers can send an invalid token so handleAuthReque…

  • High 7.4

    vault-java-driver: SslConfig silently disables requested TLS verification

    vault-java-driver, a Java client for HashiCorp Vault, silently disables TLS certificate and hostname verification in three states where the caller asked for verification: an SslConfig passed to VaultConfig without calling build(), an SslConfig restored by Jav…

  • High 7.4

    Not Failing Securely ('Failing Open') in hMailServer

    Progressive Robot hMailServer 6.0.0 through 6.3.5 fails open when applying DANE (RFC 7672) to outbound SMTP delivery. The server's validating DNSSEC resolver treated a TLSA or MX lookup that did not complete (no answer, SERVFAIL, a malformed reply), an answer…

  • High 7.4

    @bytebase/dbhub's read-only mode does not prevent database writes

    DBHub is a database MCP server for Postgres, MySQL, SQL Server, Oracle, MariaDB, SQLite. Prior to version 0.22.6, setting `readonly = true` on the `execute_sql` tool does not make the connection read-only. The connectors are written to set PostgreSQL `default…

  • High 7.4

    AuthPoint Gateway Improper Authentication in LDAP Sync Allows First-Factor Authentication Bypass

    A missing/improper authentication vulnerability in the WatchGuard AuthPoint Gateway's LDAP Sync first-factor authentication allows a remote attacker to bypass single-factor password verification under non-default operating conditions. Additional authenticatio…

  • High 8.1

    Tinyauth: forward-auth per-app ACL is matched case-sensitively against the (case-insensitive) hostname, letting an authenticated user reach apps they are not on the allowlist for

    Tinyauth is an authentication and authorization server. Prior to 5.1.2, Tinyauth compares forwarded hostnames case-sensitively while reverse proxies route equivalent hostnames case-insensitively, allowing an authenticated low-privilege user to bypass per-app …

  • High 7.7

    djust: Multi-tenant isolation fails open on the WebSocket/SSE path, disclosing other tenants' data

    djust provides Phoenix LiveView-style reactive server-side rendering for Django with Rust-powered performance. Prior to version 1.0.7, `djust.tenants` isolation was enforced only on the HTTP path. The current tenant was stored in `threading.local()` and set e…

  • High 8.2

    Visual Studio Code Security Feature Bypass Vulnerability

    Not failing securely ('failing open') in Visual Studio Code allows an unauthorized attacker to bypass a security feature over a network.

  • High 7.9
    CVE-2026-85649 Public exploit

    (Holloway) Chew, Kean Ho's Actualizer v1.2.0 and earlier contains a fail-open password validation vulnerability in the …

  • High 8.2

    NGINX ngx_http_js_module vulnerability

    Description NGINX JavaScript (njs) and QuickJS (qjs) engines have a vulnerability when a js_access handler performs asynchronous request body processing and an exception is thrown during asynchronous access-control evaluation before an explicit access denial …

  • High 7.4

    rsync 3.1.0 < 3.5.0 Access Control Bypass via DNS Resolution Failure

    rsync 3.1.0 before 3.5.0 contains an access control bypass vulnerability that allows remote attackers to circumvent hosts deny rules by inducing DNS resolution failures during hostname-based access control evaluation. When a DNS lookup for a hostname-based de…

  • High 7.5

    JupyterLab before 4.6.2 Authentication Bypass via PyPIExtensionManager

    JupyterLab versions >=4.6.0,<=4.6.1 and <=4.5.9 contain an allowlist/blocklist enforcement gap in PyPIExtensionManager.install(). A missing 'await' caused the is_install_allowed coroutine to never execute, so the extension allowlist/blocklist check was not en…

  • High 8.2

    Visual Studio Code Security Feature Bypass Vulnerability

    Not failing securely ('failing open') in Visual Studio Code allows an unauthorized attacker to bypass a security feature over a network.

  • High 7.7

    Livebook Teams identity check fails open when the deployment group is unresolvable, allowing unauthenticated access

    Not Failing Securely ('Failing Open') vulnerability in livebook-dev livebook allows an unauthenticated network client to obtain full access to a Livebook server that enforces identity through Livebook Teams. A Livebook Agent or App Server connected to Liveboo…

  • High 8.6

    Fallback to second RAUC slot with default credentials

    An unauthenticated remote attacker can enforce the system to fall back to a firmware partition with an insecure configuration including default credentials. This could allow the attacker to gain SSH access to the system as an unprivileged user "user-app". Cha…

  • High 8.2

    SCRAM: Silent channel-binding authentication downgrade via unsupported certificate algorithms

    SCRAM (Salted Challenge Response Authentication Mechanism) is part of the family of Simple Authentication and Security Layer (SASL, RFC 4422) authentication mechanisms. Prior to 3.3, a flaw in com.ongres.scram:scram-client and com.ongres.scram:scram-common al…

  • High 8.2

    .NET Security Feature Bypass Vulnerability

    Incorrect authorization in .NET allows an unauthorized attacker to bypass a security feature over a network.

  • High 8.2

    Silent channel-binding authentication downgrade via unsupported certificate algorithms

    pgjdbc is an open source postgresql JDBC Driver. In releases 42.7.4 through 42.7.11, channelBinding=require connections can be silently downgraded from SCRAM-SHA-256-PLUS with channel binding to plain SCRAM-SHA-256 without it, losing the man-in-the-middle pro…

  • High 7.6

    net-imap vulnerable to STARTTLS stripping via invalid response timing

    Net::IMAP implements Internet Message Access Protocol (IMAP) client functionality in Ruby. Prior to versions 0.3.10, 0.4.24, 0.5.14, and 0.6.4, a man-in-the-middle attacker can cause Net::IMAP#starttls to return "successfully", without starting TLS. This issu…

  • High 7.5

    OpenClaw < 2026.4.8 - strictInlineEval Approval Boundary Bypass via Approval-Timeout Fallback

    OpenClaw before 2026.4.8 contains an approval-timeout fallback mechanism that bypasses strictInlineEval explicit-approval requirements on gateway and node exec hosts. Attackers can exploit this timeout fallback to execute inline eval commands that should requ…

  • High 8.7

    free5gc UDR improper path validation allows unauthenticated creation and modification of Traffic Influence Subscriptions

    free5GC is an open-source implementation of the 5G core network. In versions 4.2.1 and below of the UDR service, the handler for creating or updating Traffic Influence Subscriptions checks whether the influenceId path segment equals subs-to-notify, but does n…

  • High 8.7

    free5gc UDR improper path validation allows unauthenticated access to Traffic Influence Subscriptions

    free5GC is an open-source implementation of the 5G core network. In versions 4.2.1 and below of the UDR service, the handler for reading Traffic Influence Subscriptions checks whether the influenceId path segment equals subs-to-notify, but does not return aft…

  • High 8.4

    Helm's plugin verification fails open when .prov is missing, allowing unsigned plugin install

    Helm is a package manager for Charts for Kubernetes. From 4.0.0 to 4.1.3, Helm will install plugins missing provenance (.prov file) when signature verification is required. This vulnerability is fixed in 4.1.4.

  • High 7.5

    fast-jwt accepts unknown `crit` header extensions (RFC 7515 §4.1.11 MUST violation)

    fast-jwt provides fast JSON Web Token (JWT) implementation. In 6.1.0 and earlier, fast-jwt does not validate the crit (Critical) Header Parameter defined in RFC 7515 §4.1.11. When a JWS token contains a crit array listing extensions that fast-jwt does not und…

  • High 8.7

    VTun-ng's failure to initialize encryption modules may cause reversion to plaintext

    VTun-ng is a Virtual Tunnel over TCP/IP network. In versions 3.0.17 and below, failure to initialize encryption modules might cause reversion to plaintext due to insufficient error handling. The bug was first introduced in VTun-ng version 3.0.12. This is fixe…

  • High 7.5

    Vault Vulnerable to Denial of Service When Processing Raft Join Requests

    Vault Community and Vault Enterprise (“Vault”) clusters using Vault’s Integrated Storage backend are vulnerable to a denial-of-service (DoS) attack through memory exhaustion through a Raft cluster join API endpoint . An attacker may send a large volume of req…

  • High 8.8
    CVE-2024-43532 EPSS 12%

    Remote Registry Service Elevation of Privilege Vulnerability

    Remote Registry Service Elevation of Privilege Vulnerability

  • High 8.4

    A vulnerability was reported in BIOS for ThinkPad P14s Gen 2, P15s Gen 2, T14 Gen 2, and T15 Gen 2 that could cause the…

  • High 7.5

    moby/moby's dockerd daemon encrypted overlay network may be unauthenticated

    Moby is an open source container framework developed by Docker Inc. that is distributed as Docker, Mirantis Container Runtime, and various other downstream projects/products. The Moby daemon component (`dockerd`), which is developed as moby/moby, is commonly …

  • High 8.8

    Cisco Application Policy Infrastructure Controller Privilege Escalation Vulnerability

    A vulnerability in an API endpoint of Cisco Application Policy Infrastructure Controller (APIC) and Cisco Cloud Application Policy Infrastructure Controller (Cloud APIC) could allow an authenticated, remote attacker to elevate privileges to Administrator on a…