Skip to content
OpenAdvisories

Package · Debian

sqlite3

76 known vulnerabilities.

11 results · Clear filters · Feed

  • High 7.8

    SQLite CLI through 3.54.1 Command Injection via .recover Output

    SQLite command-line shell through 3.54.1 contains a command injection vulnerability in the .recover command that emits attacker-planted dot-commands stored in sqlite_schema.sql values verbatim. Attackers can craft a database whose schema holds a valid CREATE …

  • High 7.8

    SQLite before 3.54.0 Heap Buffer Overflow via Session Extension sessionUpdateFind()

    SQLite before 3.54.0 built with the session extension contains a heap buffer overflow vulnerability in sqlite3changeset_apply() that allows attackers to corrupt heap memory by supplying crafted changesets. Attackers can repeat a table name in a second changes…

  • High 7.8

    SQLite before 3.54.0 Heap Buffer Overflow via FTS5 fts5DoSecureDelete()

    SQLite before 3.54.0 built with FTS5 contains a heap buffer overflow in fts5DoSecureDelete() that allows attackers to write past the leaf page buffer via crafted footer key offsets. Attackers can supply a database file with a corrupted FTS5 index that, when d…

  • High 7.8

    SQLite before 3.54.0 FTS5 Heap Buffer Overflow via fts5MergeRowidLists()

    SQLite before 3.54.0 built with FTS5 contains a heap buffer overflow in fts5MergeRowidLists() that undersizes the output buffer when merging detail=none prefix doclists. Attackers who can populate a detail=none FTS5 table with negative rowids and run a prefix…

  • High 7.8

    SQLite before 3.53.2 Heap Buffer Overflow via FTS5 fts5ChunkIterate

    SQLite before 3.53.2 contains a heap-based buffer overflow vulnerability in the FTS5 full-text search extension that allows attackers to cause a crash or execute arbitrary code by supplying a crafted database with malicious continuation page metadata specifyi…

  • High 7.5

    An information disclosure issue in the zipfileInflate function in the zipfile extension in SQLite v3.51.1 and earlier a…

  • High 7.2
    CVE-2025-6965 Public exploit EPSS 73%

    Integer Truncation on SQLite

    There exists a vulnerability in SQLite versions before 3.50.2 where the number of aggregate terms could exceed the number of columns available. This could lead to a memory corruption issue. We recommend upgrading to version 3.50.2 or above.

  • High 7.5

    An issue found in SQLite SQLite3 v.3.35.4 that allows a remote attacker to cause a denial of service via the appendvfs.…

  • High 7.3

    SQLite through 3.40.0, when relying on --safe for execution of an untrusted CLI script, does not properly implement the…

  • High 7.5
    CVE-2022-35737 Public exploit EPSS 24%

    `libsqlite3-sys` via C SQLite improperly validates array index

    SQLite 1.0.12 through 3.39.x before 3.39.2 sometimes allows an array-bounds overflow if billions of bytes are used in a string argument to a C API.

  • High 8.1

    An exploitable use after free vulnerability exists in the window function functionality of Sqlite3 3.26.0. A specially …