Skip to content
OpenAdvisories

Vendor

WordPress

39 known vulnerabilities.

21 results · Clear filters · Feed

  • Medium 5.9
    CVE-2026-60137 Exploited Public exploit

    WordPress < 7.0.2 - Facilitated SQL Injection via author__not_in in WP_Query

    WordPress 6.8.x before 6.8.6, 6.9.x before 6.9.5, and 7.0.x before 7.0.2 does not properly sanitise the author__not_in parameter of WP_Query, which could allow SQL Injection when a plugin or theme passes untrusted input to the parameter.

    KEV Jul 21, 2026
  • Medium 6.4

    WordPress Plugin Buddypress 6.2.0 Persistent Cross-Site Scripting

    WordPress Plugin Buddypress 6.2.0 contains a persistent cross-site scripting vulnerability that allows authenticated attackers with moderator privileges to inject malicious script code through the figure parameter in wp:html blocks. Attackers can inject ifram…

  • Medium 5.9

    WordPress <= 6.8.2 - (Author+) Cross Site Scripting (XSS) Vulnerability

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WordPress allows Stored XSS. WordPress core security team is aware of the issue and working on a fix. This is low severity vulnerability that requires an att…

  • Medium 4.3

    WordPress <= 6.8.2 - (Contributor+) Sensitive Data Exposure Vulnerability

    Insertion of Sensitive Information Into Sent Data vulnerability in WordPress allows Retrieve Embedded Sensitive Data. The WordPress Core security team is aware of the issue and is already working on a fix. This is a low-severity vulnerability. Contributor-lev…

  • Medium 5.5
    CVE-2024-31211 Public exploit

    Remote Code Execution in `WP_HTML_Token`

    WordPress is an open publishing platform for the Web. Unserialization of instances of the `WP_HTML_Token` class allows for code execution via its `__destruct()` magic method. This issue was fixed in WordPress 6.4.2 on December 6th, 2023. Versions prior to 6.4…

  • Medium 5.3
    CVE-2023-5561 Public exploit

    WordPress < 6.3.2 - Unauthenticated Post Author Email Disclosure

    WordPress does not properly restrict which user fields are searchable via the REST API, allowing unauthenticated attackers to discern the email addresses of users who have published public posts on an affected website via an Oracle style attack

  • Medium 5.9
    CVE-2022-3590 Public exploit

    WP <= 6.1.1 - Unauthenticated Blind SSRF via DNS Rebinding

    WordPress is affected by an unauthenticated blind SSRF in the pingback feature. Because of a TOCTOU race condition between the validation checks and the HTTP request, attackers can reach internal hosts that are explicitly forbidden.

  • Medium 6.6

    Authenticated Object Injection in Multisites in WordPress

    WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database. On a multisite, users with Super Admin role can bypass explicit/additional hardening under certain conditions through object injection. This has b…

  • Medium 6.8

    Private data disclosure/privilege escalation through the block editor in Wordpress

    WordPress is a free and open-source content management system written in PHP and paired with a MySQL or MariaDB database. In affected versions authenticated users who don't have permission to view private post types/data can bypass restrictions in the block e…

  • Medium 5.3

    Information Disclosure in wp_die() via JSONP in wordpress

    WordPress is a free and open-source content management system written in PHP and paired with a MySQL or MariaDB database. In affected versions output data of the function wp_die() can be leaked under certain conditions, which can include data like nonces. It …

  • Medium 6.5

    WordPress Authenticated disclosure of password-protected posts and pages

    Wordpress is an open source CMS. One of the blocks in the WordPress editor can be exploited in a way that exposes password-protected posts and pages. This requires at least contributor privileges. This has been patched in WordPress 5.7.1, along with the older…

  • Medium 6.8

    Authenticated XSS via media attachment page in WordPress

    In affected versions of WordPress, authenticated users with upload permissions (like authors) are able to inject JavaScript into some media file attachment pages in a certain way. This can lead to script execution in the context of a higher privileged user wh…

  • Medium 5.7

    Open redirect in wp_validate_redirect() in WordPress

    In affected versions of WordPress, due to an issue in wp_validate_redirect() and URL sanitization, an arbitrary external link can be crafted leading to unintended/open redirect when clicked. This has been patched in version 5.4.2, along with all the previousl…

  • Medium 5.4

    Authenticated XSS through embed block in WordPress

    In affected versions of WordPress, users with low privileges (like contributors and authors) can use the embed block in a certain way to inject unfiltered HTML in the block editor. When affected posts are viewed by a higher privileged user, this could lead to…

  • Medium 5.8

    Unauthenticated disclosure of certain private posts in WordPress

    In affected versions of WordPress, some private posts, which were previously public, can result in unauthenticated disclosure under a specific set of conditions. This has been patched in version 5.4.1, along with all the previously affected versions via a min…

  • Medium 5.8

    Cross-site scripting in stats method (object cache) in WordPress

    In affected versions of WordPress, a vulnerability in the stats() method of class-wp-object-cache.php can be exploited to execute cross-site scripting (XSS) attacks. This has been patched in version 5.4.1, along with all the previously affected versions via a…

  • Medium 6.4

    Cross-site scripting (XSS) in Search block in WordPress

    In affected versions of WordPress, a special payload can be crafted that can lead to scripts getting executed within the search block of the block editor. This requires an authenticated user with the ability to add content. This has been patched in version 5.…

  • Medium 5.8

    Authenticated cross-site scripting (XSS) in WordPress Customizer

    In affected versions of WordPress, a cross-site scripting (XSS) vulnerability in the navigation section of Customizer allows JavaScript code to be executed. Exploitation requires an authenticated user. This has been patched in version 5.4.1, along with all th…

  • Medium 6.1
    CVE-2020-11027 Public exploit EPSS 14%

    Password reset links invalidation issue in WordPress

    In affected versions of WordPress, a password reset link emailed to a user does not expire upon changing the user password. Access would be needed to the email account of the user by a malicious party for successful execution. This has been patched in version…

  • Medium 5.8

    Stored cross-site scripting (XSS) in WordPress block editor

    In WordPress before 5.3.1, authenticated users with lower privileges (like contributors) can inject JavaScript code in the block editor, which is executed within the dashboard. It can lead to an admin opening the affected post in the editor leading to XSS.

  • Medium 5.8

    Stored cross-site scripting (XSS) in WordPress block editor

    WordPress users with lower privileges (like contributors) can inject JavaScript code in the block editor using a specific payload, which is executed within the dashboard. This can lead to XSS if an admin opens the post in the editor. Execution of this attack …