Skip to content
OpenAdvisories
High ALAS2-2024-2481 2 CVEs

Important: unbound security update (Amazon Linux 2)

Published Feb 29, 2024 · Updated Mar 4, 2024

Summary

Package updates are available for Amazon Linux 2 that fix the following vulnerabilities: CVE-2023-50868: The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification implies that an algorithm must perform thousands of iterations of a hash function in certain situations. CVE-2023-50387: Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses when there is a zone with many DNSKEY and RRSIG records, aka the "KeyTrap" issue. The protocol specification implies that an algorithm must evaluate all combinations of DNSKEY and RRSIG records.

Fixed packages 6

ReleasePackageFixed in
Amazon Linux · 2 python2-unbound 0:1.7.3-15.amzn2.0.7
Amazon Linux · 2 python3-unbound 0:1.7.3-15.amzn2.0.7
Amazon Linux · 2 unbound 0:1.7.3-15.amzn2.0.7
Amazon Linux · 2 unbound-debuginfo 0:1.7.3-15.amzn2.0.7
Amazon Linux · 2 unbound-devel 0:1.7.3-15.amzn2.0.7
Amazon Linux · 2 unbound-libs 0:1.7.3-15.amzn2.0.7

Vulnerabilities 2

References

  • web
    https://alas.aws.amazon.com/cve/html/CVE-2023-50387.html
  • web
    https://alas.aws.amazon.com/cve/html/CVE-2023-50868.html