Summary
Package updates are available for Amazon Linux 2 that fix the following vulnerabilities: CVE-2023-50868: The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification implies that an algorithm must perform thousands of iterations of a hash function in certain situations. CVE-2023-50387: Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses when there is a zone with many DNSKEY and RRSIG records, aka the "KeyTrap" issue. The protocol specification implies that an algorithm must evaluate all combinations of DNSKEY and RRSIG records.
Fixed packages 17
| Release | Package | Fixed in |
|---|---|---|
| Amazon Linux · 2 | bind | 32:9.11.4-26.P2.amzn2.13.6 |
| Amazon Linux · 2 | bind-chroot | 32:9.11.4-26.P2.amzn2.13.6 |
| Amazon Linux · 2 | bind-debuginfo | 32:9.11.4-26.P2.amzn2.13.6 |
| Amazon Linux · 2 | bind-devel | 32:9.11.4-26.P2.amzn2.13.6 |
| Amazon Linux · 2 | bind-export-devel | 32:9.11.4-26.P2.amzn2.13.6 |
| Amazon Linux · 2 | bind-export-libs | 32:9.11.4-26.P2.amzn2.13.6 |
| Amazon Linux · 2 | bind-libs | 32:9.11.4-26.P2.amzn2.13.6 |
| Amazon Linux · 2 | bind-libs-lite | 32:9.11.4-26.P2.amzn2.13.6 |
| Amazon Linux · 2 | bind-license | 32:9.11.4-26.P2.amzn2.13.6 |
| Amazon Linux · 2 | bind-lite-devel | 32:9.11.4-26.P2.amzn2.13.6 |
| Amazon Linux · 2 | bind-pkcs11 | 32:9.11.4-26.P2.amzn2.13.6 |
| Amazon Linux · 2 | bind-pkcs11-devel | 32:9.11.4-26.P2.amzn2.13.6 |
| Amazon Linux · 2 | bind-pkcs11-libs | 32:9.11.4-26.P2.amzn2.13.6 |
| Amazon Linux · 2 | bind-pkcs11-utils | 32:9.11.4-26.P2.amzn2.13.6 |
| Amazon Linux · 2 | bind-sdb | 32:9.11.4-26.P2.amzn2.13.6 |
| Amazon Linux · 2 | bind-sdb-chroot | 32:9.11.4-26.P2.amzn2.13.6 |
| Amazon Linux · 2 | bind-utils | 32:9.11.4-26.P2.amzn2.13.6 |
Vulnerabilities 2
-
High 7.5
Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to …
-
High 7.5
The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote att…