Skip to content
OpenAdvisories
High ALAS2023-2024-553 2 CVEs

Important: unbound security update (Amazon Linux 2023)

Published Feb 29, 2024 · Updated Mar 5, 2024

Summary

Package updates are available for Amazon Linux 2023 that fix the following vulnerabilities: CVE-2023-50868: The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification implies that an algorithm must perform thousands of iterations of a hash function in certain situations. CVE-2023-50387: Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses when there is a zone with many DNSKEY and RRSIG records, aka the "KeyTrap" issue. The protocol specification implies that an algorithm must evaluate all combinations of DNSKEY and RRSIG records.

Fixed packages 12

ReleasePackageFixed in
Amazon Linux · 2023 python3-unbound 0:1.17.1-1.amzn2023.0.2
Amazon Linux · 2023 python3-unbound-debuginfo 0:1.17.1-1.amzn2023.0.2
Amazon Linux · 2023 unbound 0:1.17.1-1.amzn2023.0.2
Amazon Linux · 2023 unbound-anchor 0:1.17.1-1.amzn2023.0.2
Amazon Linux · 2023 unbound-anchor-debuginfo 0:1.17.1-1.amzn2023.0.2
Amazon Linux · 2023 unbound-debuginfo 0:1.17.1-1.amzn2023.0.2
Amazon Linux · 2023 unbound-debugsource 0:1.17.1-1.amzn2023.0.2
Amazon Linux · 2023 unbound-devel 0:1.17.1-1.amzn2023.0.2
Amazon Linux · 2023 unbound-libs 0:1.17.1-1.amzn2023.0.2
Amazon Linux · 2023 unbound-libs-debuginfo 0:1.17.1-1.amzn2023.0.2
Amazon Linux · 2023 unbound-utils 0:1.17.1-1.amzn2023.0.2
Amazon Linux · 2023 unbound-utils-debuginfo 0:1.17.1-1.amzn2023.0.2

Vulnerabilities 2

References

  • web
    https://alas.aws.amazon.com/cve/html/CVE-2023-50387.html
  • web
    https://alas.aws.amazon.com/cve/html/CVE-2023-50868.html