Summary
The Berkeley Internet Name Domain (BIND) is an implementation of the Domain Name System (DNS) protocols. BIND includes a DNS server (named); a resolver library (routines for applications to use when interfacing with DNS); and tools for verifying that the DNS server is operating correctly.
The Dynamic Host Configuration Protocol (DHCP) is a protocol that allows individual devices on an IP network to get their own network configuration information, including an IP address, a subnet mask, and a broadcast address. The dhcp packages provide a relay agent and ISC DHCP service required to enable and administer DHCP on a network.
Security Fix(es):
* bind9: Parsing large DNS messages may cause excessive CPU load (CVE-2023-4408)
* bind9: KeyTrap - Extreme CPU consumption in DNSSEC validator (CVE-2023-50387)
* bind9: Preparing an NSEC3 closest encloser proof can exhaust CPU resources (CVE-2023-50868)
Bug Fix:
* dhcp rebuilt after API change of bind-export-libs
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Fixed packages 17
| Release | Package | Fixed in |
|---|---|---|
| AlmaLinux · 8 | bind | 32:9.11.36-14.el8_10 |
| AlmaLinux · 8 | bind-chroot | 32:9.11.36-14.el8_10 |
| AlmaLinux · 8 | bind-devel | 32:9.11.36-14.el8_10 |
| AlmaLinux · 8 | bind-export-devel | 32:9.11.36-14.el8_10 |
| AlmaLinux · 8 | bind-export-libs | 32:9.11.36-14.el8_10 |
| AlmaLinux · 8 | bind-libs | 32:9.11.36-14.el8_10 |
| AlmaLinux · 8 | bind-libs-lite | 32:9.11.36-14.el8_10 |
| AlmaLinux · 8 | bind-license | 32:9.11.36-14.el8_10 |
| AlmaLinux · 8 | bind-lite-devel | 32:9.11.36-14.el8_10 |
| AlmaLinux · 8 | bind-pkcs11 | 32:9.11.36-14.el8_10 |
| AlmaLinux · 8 | bind-pkcs11-devel | 32:9.11.36-14.el8_10 |
| AlmaLinux · 8 | bind-pkcs11-libs | 32:9.11.36-14.el8_10 |
| AlmaLinux · 8 | bind-pkcs11-utils | 32:9.11.36-14.el8_10 |
| AlmaLinux · 8 | bind-sdb | 32:9.11.36-14.el8_10 |
| AlmaLinux · 8 | bind-sdb-chroot | 32:9.11.36-14.el8_10 |
| AlmaLinux · 8 | bind-utils | 32:9.11.36-14.el8_10 |
| AlmaLinux · 8 | python3-bind | 32:9.11.36-14.el8_10 |
Vulnerabilities 3
-
High 7.5
Parsing large DNS messages may cause excessive CPU load
The DNS message parsing code in `named` includes a section whose computational complexity is overly high. It does not cause problems for typical DNS traffic, but crafted queries and responses may cause excessive CPU load on the affected `named` instance by ex…
-
High 7.5
Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to …
-
High 7.5
The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote att…
References
-
report
https://access.redhat.com/security/cve/CVE-2023-4408
-
report
https://access.redhat.com/security/cve/CVE-2023-50387
-
report
https://access.redhat.com/security/cve/CVE-2023-50868
-
report
https://bugzilla.redhat.com/2263896
-
report
https://bugzilla.redhat.com/2263914
-
report
https://bugzilla.redhat.com/2263917
-
advisory
https://errata.almalinux.org/8/ALSA-2024-3271.html