Summary
OpenSSL is a toolkit that implements the Secure Sockets Layer (SSL) and Transport Layer Security (TLS) protocols, as well as a full-strength general-purpose cryptography library.
Security Fix(es):
* openssl: OpenSSL: Heap buffer overflow due to signed integer overflow in Unicode output sizing (CVE-2026-7383)
* openssl: OpenSSL: Denial of Service due to heap out-of-bounds read in CMS password-based decryption (CVE-2026-9076)
* openssl: OpenSSL: Heap buffer over-read in ASN.1 decoding can lead to denial of service or information disclosure. (CVE-2026-34180)
* openssl: PKCS#12 Files with PBMAC1 Are Accepted with Short HMAC Keys (CVE-2026-34181)
* openssl: CMS AuthEnvelopedData Processing May Accept Forged Messages (CVE-2026-34182)
* openssl: Unbounded Memory Growth in the QUIC PATH_CHALLENGE Handler (CVE-2026-34183)
* openssl: NULL pointer dereference in QUIC server initial packet handling (CVE-2026-42764)
* openssl: Possible NULL Dereference in Password-Based CMS Decryption (CVE-2026-42766)
* openssl: NULL Pointer Dereference in CRMF EncryptedValue Decryption (CVE-2026-42767)
* openssl: Multi-RecipientInfo Bleichenbacher Oracle in CMS_decrypt() and PKCS7_decrypt() (CVE-2026-42768)
* openssl: Trust-Anchor Substitution via cert/issuer Typo in CMP rootCaKeyUpdate (CVE-2026-42769)
* openssl: FFC-DH Peer Validation Uses Attacker-Supplied q (CVE-2026-42770)
* openssl: AES-OCB IV Ignored on EVP_Cipher() Path (CVE-2026-45445)
* openssl: Incorrect Tag Processing for Empty Messages in AES-GCM-SIV and AES-SIV modes (CVE-2026-45446)
* openssl: Heap Use-After-Free in OpenSSL PKCS7_verify() (CVE-2026-45447)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Fixed packages 4
| Release | Package | Fixed in |
|---|---|---|
| AlmaLinux · 10 | openssl | 1:3.5.5-4.el10_2.alma.1 |
| AlmaLinux · 10 | openssl-devel | 1:3.5.5-4.el10_2.alma.1 |
| AlmaLinux · 10 | openssl-libs | 1:3.5.5-4.el10_2.alma.1 |
| AlmaLinux · 10 | openssl-perl | 1:3.5.5-4.el10_2.alma.1 |
Vulnerabilities 15
-
Critical 9.1
CMS AuthEnvelopedData Processing May Accept Forged Messages
Issue Summary: Cryptographic Message Services (CMS) processing fails to perform sufficient input validation on the cipher and tag length fields of AuthEnvelopedData containers, leading to various potential compromises. Impact Summary: Attackers making use of …
-
High 8.8CVE-2026-45447 Public exploit
Heap Use-After-Free in the PKCS7_verify() Function
Issue summary: A specially crafted PKCS#7 or S/MIME signed message could trigger a use-after-free during PKCS#7 signature verification. Impact summary: A use-after-free may result in process crashes, heap corruption, or potentially remote code execution. When…
-
High 8.1
Possible Heap Buffer Overflow in ASN.1 Multibyte String Conversion
Issue summary: A signed integer overflow when sizing the destination buffer for Unicode output in ASN1_mbstring_ncopy() can lead to a heap buffer overflow. Impact summary: A heap buffer overflow may lead to a crash or possibly attacker controlled code executi…
-
High 7.5
Heap Buffer Over-read in ASN.1 Content Parsing
Issue summary: Parsing a crafted DER-encoded ASN.1 structure with a primitive element whose content exceeds 2 gigabytes in length may cause a heap buffer over-read on 64-bit Unix and Unix-like platforms. Impact summary: The heap buffer over-read may crash the…
-
High 7.5
Unbounded Memory Growth in the QUIC PATH_CHALLENGE Handler
Issue summary: Remote peer may exhaust heap memory of the QUIC server or client by flooding it with packets containing PATH_CHALLENGE frames. Impact summary: A malicious remote peer can cause an unbounded memory allocation which can lead to an abnormal termin…
-
High 7.5
NULL Pointer Dereference in QUIC Server Initial Packet Handling
Issue summary: Receiving a QUIC initial packet with an invalid token may trigger a NULL pointer dereference in the OpenSSL QUIC server with address validation disabled. Impact summary: NULL pointer dereference typically causes abnormal termination of the affe…
-
High 7.5
AES-OCB IV Ignored on EVP_Cipher() Path
Issue summary: When an application drives an AES-OCB context through the public EVP_Cipher() one-shot interface, the application-supplied initialisation vector (IV) is silently discarded. Impact summary: Every message encrypted under the same key uses the sam…
-
High 7.5
Out-of-Bounds Read in CMS Password-Based Decryption
Issue summary: When CMS password-based decryption (RFC 3211 / PWRI key unwrap) processes attacker-supplied CMS data, an attacker-chosen stream-mode KEK cipher can trigger a heap out-of-bounds read in kek_unwrap_key(). Impact summary: A heap buffer over-read m…
-
High 7.4
PKCS#12 Files with PBMAC1 Are Accepted with Short HMAC Keys
Issue Summary: The PKCS#12 file processing fails to perform sufficient input validation for files that use Password-Based Message Authentication Code 1 (PBMAC1) integrity mechanism allowing a certificate and private key forgery. Impact Summary: An attacker im…
-
Medium 5.9
Possible NULL Dereference in Password-Based CMS Decryption
Issue summary: A specially crafted password-encrypted CMS message can trigger a NULL pointer dereference during CMS decryption. Impact summary: This NULL pointer dereference leads to an application crash and a Denial of Service. The CMS PasswordRecipientInfo.…
-
Medium 5.9
NULL Pointer Dereference in CRMF EncryptedValue Decryption
Issue summary: An attacker-controlled CMP (Certificate Management Protocol) server could trigger a NULL pointer dereference in a CMP client application. Impact summary: A NULL pointer dereference causes a crash of the application and a Denial of Service. An a…
-
Medium 5.3
Trust-Anchor Substitution via cert/issuer Typo in CMP rootCaKeyUpdate
Issue Summary: An error in the callback used to verify the certificate provided in a Root CA key update Certificate Management Protocol (CMP) message response rendered the certificate validation ineffectual, which could lead to escalation of credentials from …
-
Medium 4.8
Incorrect Tag Processing for Empty Messages in AES-GCM-SIV and AES-SIV modes
Issue summary: The implementations of AES-SIV (RFC 5297) and AES-GCM-SIV (RFC 8452) mishandle the authentication of AAD (Additional Authenticated Data) with an empty ciphertext allowing a forgery of such messages. Impact summary: An attacker can forge empty m…
-
Low 3.7
Multi-RecipientInfo Bleichenbacher Oracle in CMS_decrypt() and PKCS7_decrypt()
Issue summary: The CMS_decrypt and PKCS7_decrypt functions are vulnerable to Bleichenbacher-style attack when an attacker is able to provide the CMS or S/MIME messages and observe the error code and/or decryption output. Impact summary: The Bleichenbacher-sty…
-
Low 3.7
FFC-DH Peer Validation Uses Attacker-Supplied q
Issue summary: When EVP_PKEY_derive_set_peer() is called with a DHX (X9.42) peer key, the peer key is not properly checked for the subgroup membership. Impact summary: A malicious peer which presents an X9.42 key carrying the victim's p and g parameters, a fo…
References
-
report
https://access.redhat.com/security/cve/CVE-2026-34180
-
report
https://access.redhat.com/security/cve/CVE-2026-34181
-
report
https://access.redhat.com/security/cve/CVE-2026-34182
-
report
https://access.redhat.com/security/cve/CVE-2026-34183
-
report
https://access.redhat.com/security/cve/CVE-2026-42764
-
report
https://access.redhat.com/security/cve/CVE-2026-42766
-
report
https://access.redhat.com/security/cve/CVE-2026-42767
-
report
https://access.redhat.com/security/cve/CVE-2026-42768
-
report
https://access.redhat.com/security/cve/CVE-2026-42769
-
report
https://access.redhat.com/security/cve/CVE-2026-42770
-
report
https://access.redhat.com/security/cve/CVE-2026-45445
-
report
https://access.redhat.com/security/cve/CVE-2026-45446
-
report
https://access.redhat.com/security/cve/CVE-2026-45447
-
report
https://access.redhat.com/security/cve/CVE-2026-7383
-
report
https://access.redhat.com/security/cve/CVE-2026-9076
-
report
https://bugzilla.redhat.com/2481879
-
report
https://bugzilla.redhat.com/2481880
-
report
https://bugzilla.redhat.com/2481881
-
report
https://bugzilla.redhat.com/2481882
-
report
https://bugzilla.redhat.com/2481884
-
report
https://bugzilla.redhat.com/2481885
-
report
https://bugzilla.redhat.com/2481887
-
report
https://bugzilla.redhat.com/2481890
-
report
https://bugzilla.redhat.com/2481891
-
report
https://bugzilla.redhat.com/2481892
-
report
https://bugzilla.redhat.com/2481893
-
report
https://bugzilla.redhat.com/2481894
-
report
https://bugzilla.redhat.com/2481896
-
report
https://bugzilla.redhat.com/2481897
-
report
https://bugzilla.redhat.com/2481898
-
advisory
https://errata.almalinux.org/10/ALSA-2026-25237.html