Skip to content
OpenAdvisories
High DSA-5621-1 5 CVEs

bind9 - security update

Published Feb 14, 2024 · Updated Mar 9, 2026

Fixed packages 2

ReleasePackageFixed in
Debian · 11 bind9 1:9.16.48-1
Debian · 12 bind9 1:9.18.24-1

Vulnerabilities 5

  • High 7.5

    Parsing large DNS messages may cause excessive CPU load

    The DNS message parsing code in `named` includes a section whose computational complexity is overly high. It does not cause problems for typical DNS traffic, but crafted queries and responses may cause excessive CPU load on the affected `named` instance by ex…

  • High 7.5
    CVE-2023-50387 Public exploit EPSS 100%

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to …

  • High 7.5
    CVE-2023-50868 Public exploit EPSS 74%

    The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote att…

  • High 7.5

    Querying RFC 1918 reverse zones may cause an assertion failure when "nxdomain-redirect" is enabled

    A flaw in query-handling code can cause `named` to exit prematurely with an assertion failure when: - `nxdomain-redirect <domain>;` is configured, and - the resolver receives a PTR query for an RFC 1918 address that would normally result in an authoritative N…

  • High 7.5

    Enabling both DNS64 and serve-stale may cause an assertion failure during recursive resolution

    A bad interaction between DNS64 and serve-stale may cause `named` to crash with an assertion failure during recursive resolution, when both of these features are enabled. This issue affects BIND 9 versions 9.16.12 through 9.16.45, 9.18.0 through 9.18.21, 9.19…