Summary
[2.79-31.2]
- Fix CVE 2023-50387 and CVE 2023-50868
- Resolves: RHEL-25628
- Resolves: RHEL-25666
[2.79-31.1]
- Do not crash on invalid domain in --synth-domain option (RHEL-22741)
[2.79-31]
- Do not create and search --local and --address=/x/# domains (#2233542)
[2.79-30]
- Make create logfile writeable by root (#2156789)
[2.79-29]
- Fix also dynamically set resolvers over dbus (#2186481)
[2.79-28]
- Correct possible crashes when server=/example.net/# is used (#2186481)
[2.79-27]
- Limit offered EDNS0 size to 1232 (CVE-2023-28450)
Fixed packages 2
| Release | Package | Fixed in |
|---|---|---|
| Oracle Linux · 8 | dnsmasq | 0:2.79-31.el8_9.2 |
| Oracle Linux · 8 | dnsmasq-utils | 0:2.79-31.el8_9.2 |
Vulnerabilities 2
-
High 7.5
Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to …
-
High 7.5
The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote att…