Skip to content
OpenAdvisories
High ELSA-2024-1781 6 CVEs

Important: bind9.16 security update (Oracle Linux 8)

Published Apr 11, 2024 · Updated Apr 11, 2024

Summary

[32:9.16.23-0.16.2]
- Prevent crashing at masterformat system test (CVE-2023-6516)

[32:9.16.23-0.16.1]
- Prevent increased CPU load on large DNS messages (CVE-2023-4408)
- Prevent assertion failure when nxdomain-redirect is used with
RFC 1918 reverse zones (CVE-2023-5517)
- Prevent assertion failure if DNS64 and serve-stale is used (CVE-2023-5679)
- Specific recursive query patterns may lead to an out-of-memory
condition (CVE-2023-6516)
- Prevent increased CPU consumption in DNSSEC validator (CVE-2023-50387
CVE-2023-50868)
- Import tests for large DNS messages fix
- Add downstream change complementing CVE-2023-50387

[32:9.16.23-0.16]
- Limit the amount of recursion possible in control channel (CVE-2023-3341)

[32:9.16.23-0.15]
- Strengten cache cleaning to prevent overflowing configured limit
(CVE-2023-2828)

Fixed packages 9

ReleasePackageFixed in
Oracle Linux · 8 bind9.16 32:9.16.23-0.16.el8_9.2
Oracle Linux · 8 bind9.16-chroot 32:9.16.23-0.16.el8_9.2
Oracle Linux · 8 bind9.16-devel 32:9.16.23-0.16.el8_9.2
Oracle Linux · 8 bind9.16-dnssec-utils 32:9.16.23-0.16.el8_9.2
Oracle Linux · 8 bind9.16-doc 32:9.16.23-0.16.el8_9.2
Oracle Linux · 8 bind9.16-libs 32:9.16.23-0.16.el8_9.2
Oracle Linux · 8 bind9.16-license 32:9.16.23-0.16.el8_9.2
Oracle Linux · 8 bind9.16-utils 32:9.16.23-0.16.el8_9.2
Oracle Linux · 8 python3-bind9.16 32:9.16.23-0.16.el8_9.2

Vulnerabilities 6

  • High 7.5

    Parsing large DNS messages may cause excessive CPU load

    The DNS message parsing code in `named` includes a section whose computational complexity is overly high. It does not cause problems for typical DNS traffic, but crafted queries and responses may cause excessive CPU load on the affected `named` instance by ex…

  • High 7.5
    CVE-2023-50387 Public exploit EPSS 100%

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to …

  • High 7.5
    CVE-2023-50868 Public exploit EPSS 74%

    The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote att…

  • High 7.5

    Querying RFC 1918 reverse zones may cause an assertion failure when "nxdomain-redirect" is enabled

    A flaw in query-handling code can cause `named` to exit prematurely with an assertion failure when: - `nxdomain-redirect <domain>;` is configured, and - the resolver receives a PTR query for an RFC 1918 address that would normally result in an authoritative N…

  • High 7.5

    Enabling both DNS64 and serve-stale may cause an assertion failure during recursive resolution

    A bad interaction between DNS64 and serve-stale may cause `named` to crash with an assertion failure during recursive resolution, when both of these features are enabled. This issue affects BIND 9 versions 9.16.12 through 9.16.45, 9.18.0 through 9.18.21, 9.19…

  • High 7.5

    Specific recursive query patterns may lead to an out-of-memory condition

    To keep its cache database efficient, `named` running as a recursive resolver occasionally attempts to clean up the database. It uses several methods, including some that are asynchronous: a small chunk of memory pointing to the cache element that can be clea…