Summary
bind
[32:9.16.23-14.4]
- Rebuild with correct z-stream tag again
[32:9.16.23-14.3]
- Rebuild together with bind-dyndb-ldap to adjust ABI changes
[32:9.16.23-14.2]
- Import tests for large DNS messages fix
- Add downstream change complementing CVE-2023-50387
[32:9.16.23-14.1]
- Prevent increased CPU load on large DNS messages (CVE-2023-4408)
- Prevent assertion failure when nxdomain-redirect is used with
RFC 1918 reverse zones (CVE-2023-5517)
- Prevent assertion failure if DNS64 and serve-stale is used (CVE-2023-5679)
- Specific recursive query patterns may lead to an out-of-memory
condition (CVE-2023-6516)
- Prevent increased CPU consumption in DNSSEC validator (CVE-2023-50387
CVE-2023-50868)
bind-dyndb-ldap
[11.9-8.3]
- Rebuild with correct z-stream tag again
[11.9-8.2]
- Rebuild required for BIND changes for KeyTrap change (CVE-2023-50387)
Fixed packages 11
| Release | Package | Fixed in |
|---|---|---|
| Oracle Linux · 9 | bind | 32:9.16.23-14.el9_3.4 |
| Oracle Linux · 9 | bind-chroot | 32:9.16.23-14.el9_3.4 |
| Oracle Linux · 9 | bind-devel | 32:9.16.23-14.el9_3.4 |
| Oracle Linux · 9 | bind-dnssec-doc | 32:9.16.23-14.el9_3.4 |
| Oracle Linux · 9 | bind-dnssec-utils | 32:9.16.23-14.el9_3.4 |
| Oracle Linux · 9 | bind-doc | 32:9.16.23-14.el9_3.4 |
| Oracle Linux · 9 | bind-dyndb-ldap | 0:11.9-8.el9_3.3 |
| Oracle Linux · 9 | bind-libs | 32:9.16.23-14.el9_3.4 |
| Oracle Linux · 9 | bind-license | 32:9.16.23-14.el9_3.4 |
| Oracle Linux · 9 | bind-utils | 32:9.16.23-14.el9_3.4 |
| Oracle Linux · 9 | python3-bind | 32:9.16.23-14.el9_3.4 |
Vulnerabilities 6
-
High 7.5
Parsing large DNS messages may cause excessive CPU load
The DNS message parsing code in `named` includes a section whose computational complexity is overly high. It does not cause problems for typical DNS traffic, but crafted queries and responses may cause excessive CPU load on the affected `named` instance by ex…
-
High 7.5
Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to …
-
High 7.5
The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote att…
-
High 7.5
Querying RFC 1918 reverse zones may cause an assertion failure when "nxdomain-redirect" is enabled
A flaw in query-handling code can cause `named` to exit prematurely with an assertion failure when: - `nxdomain-redirect <domain>;` is configured, and - the resolver receives a PTR query for an RFC 1918 address that would normally result in an authoritative N…
-
High 7.5
Enabling both DNS64 and serve-stale may cause an assertion failure during recursive resolution
A bad interaction between DNS64 and serve-stale may cause `named` to crash with an assertion failure during recursive resolution, when both of these features are enabled. This issue affects BIND 9 versions 9.16.12 through 9.16.45, 9.18.0 through 9.18.21, 9.19…
-
High 7.5
Specific recursive query patterns may lead to an out-of-memory condition
To keep its cache database efficient, `named` running as a recursive resolver occasionally attempts to clean up the database. It uses several methods, including some that are asynchronous: a small chunk of memory pointing to the cache element that can be clea…