Summary
bind
[32:9.11.4-26.P2.16]
- Prevent increased CPU consumption in DNSSEC validator (CVE-2023-50387
CVE-2023-50868)
- Add missing design by contract tests to dns_catz*
- Speed up parsing of DNS messages with many different names (CVE-2023-4408)
- Do not use header_prev in expire_lru_headers
bind-dyndb-ldap
[11.1-7.1]
- Rebuild required for BIND changes for KeyTrap change (CVE-2023-50387)
dhcp
[12:4.2.5-83.0.3.2]
- Update bug reporting URL [Orabug: 35496820]
- Direct users to Oracle Linux support site.
[12:4.2.5-83.2]
- Rebuild because of bind ABI changes related to CVE-2023-50387
Fixed packages 22
| Release | Package | Fixed in |
|---|---|---|
| Oracle Linux · 7 | bind | 32:9.11.4-26.P2.el7_9.16 |
| Oracle Linux · 7 | bind-chroot | 32:9.11.4-26.P2.el7_9.16 |
| Oracle Linux · 7 | bind-devel | 32:9.11.4-26.P2.el7_9.16 |
| Oracle Linux · 7 | bind-dyndb-ldap | 0:11.1-7.el7_9.1 |
| Oracle Linux · 7 | bind-export-devel | 32:9.11.4-26.P2.el7_9.16 |
| Oracle Linux · 7 | bind-export-libs | 32:9.11.4-26.P2.el7_9.16 |
| Oracle Linux · 7 | bind-libs | 32:9.11.4-26.P2.el7_9.16 |
| Oracle Linux · 7 | bind-libs-lite | 32:9.11.4-26.P2.el7_9.16 |
| Oracle Linux · 7 | bind-license | 32:9.11.4-26.P2.el7_9.16 |
| Oracle Linux · 7 | bind-lite-devel | 32:9.11.4-26.P2.el7_9.16 |
| Oracle Linux · 7 | bind-pkcs11 | 32:9.11.4-26.P2.el7_9.16 |
| Oracle Linux · 7 | bind-pkcs11-devel | 32:9.11.4-26.P2.el7_9.16 |
| Oracle Linux · 7 | bind-pkcs11-libs | 32:9.11.4-26.P2.el7_9.16 |
| Oracle Linux · 7 | bind-pkcs11-utils | 32:9.11.4-26.P2.el7_9.16 |
| Oracle Linux · 7 | bind-sdb | 32:9.11.4-26.P2.el7_9.16 |
| Oracle Linux · 7 | bind-sdb-chroot | 32:9.11.4-26.P2.el7_9.16 |
| Oracle Linux · 7 | bind-utils | 32:9.11.4-26.P2.el7_9.16 |
| Oracle Linux · 7 | dhclient | 12:4.2.5-83.0.3.el7_9.2 |
| Oracle Linux · 7 | dhcp | 12:4.2.5-83.0.3.el7_9.2 |
| Oracle Linux · 7 | dhcp-common | 12:4.2.5-83.0.3.el7_9.2 |
| Oracle Linux · 7 | dhcp-devel | 12:4.2.5-83.0.3.el7_9.2 |
| Oracle Linux · 7 | dhcp-libs | 12:4.2.5-83.0.3.el7_9.2 |
Vulnerabilities 3
-
High 7.5
Parsing large DNS messages may cause excessive CPU load
The DNS message parsing code in `named` includes a section whose computational complexity is overly high. It does not cause problems for typical DNS traffic, but crafted queries and responses may cause excessive CPU load on the affected `named` instance by ex…
-
High 7.5
Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to …
-
High 7.5
The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote att…