Skip to content
OpenAdvisories
Medium RHSA-2024:0855 1 CVE

Red Hat Security Advisory: Red Hat Ansible Automation Platform 2.4 Product Security and Bug Fix Update

Published Sep 16, 2024 · Updated Oct 9, 2026

Fixed packages 6

ReleasePackageFixed in
Red Hat · Ansible Automation Platform Developer 2 ansible_automation_platform_developer:2.4::el8 receptor 0:1.4.4-1.el8ap
Red Hat · Ansible Automation Platform Developer 2 ansible_automation_platform_developer:2.4::el9 receptor 0:1.4.4-1.el9ap
Red Hat · Ansible Automation Platform Inside 2 ansible_automation_platform_inside:2.4::el8 receptor 0:1.4.4-1.el8ap
Red Hat · Ansible Automation Platform Inside 2 ansible_automation_platform_inside:2.4::el9 receptor 0:1.4.4-1.el9ap
Red Hat · Ansible Automation Platform 2 ansible_automation_platform:2.4::el8 receptor 0:1.4.4-1.el8ap
Red Hat · Ansible Automation Platform 2 ansible_automation_platform:2.4::el9 receptor 0:1.4.4-1.el9ap

Vulnerabilities 1

  • Medium 6.4

    quic-go's path validation mechanism can cause denial of service

    quic-go is an implementation of the QUIC protocol (RFC 9000, RFC 9001, RFC 9002) in Go. An attacker can cause its peer to run out of memory sending a large number of PATH_CHALLENGE frames. The receiver is supposed to respond to each PATH_CHALLENGE frame with …

References

  • article
    https://access.redhat.com/security/updates/classification/#moderate
  • report
    https://bugzilla.redhat.com/show_bug.cgi?id=2257815
  • advisory
    https://security.access.redhat.com/data/csaf/v2/advisories/2024/rhsa-2024_0855.json
  • report
    https://access.redhat.com/security/cve/CVE-2023-49295
  • advisory
    https://www.cve.org/CVERecord?id=CVE-2023-49295
  • advisory
    https://nvd.nist.gov/vuln/detail/CVE-2023-49295
  • article
    https://github.com/quic-go/quic-go/security/advisories/GHSA-ppxx-5m9h-6vxf
  • article
    https://seemann.io/posts/2023-12-18-exploiting-quics-path-validation/