Skip to content
OpenAdvisories
Medium · 6.4 CVE-2023-49295 EUVD-2024-0394GHSA-ppxx-5m9h-6vxfGO-2024-2459

quic-go's path validation mechanism can cause denial of service

Published Jan 10, 2024 · Updated Jun 17, 2025 · Assigned by GitHub_M

Description

quic-go is an implementation of the QUIC protocol (RFC 9000, RFC 9001, RFC 9002) in Go. An attacker can cause its peer to run out of memory sending a large number of PATH_CHALLENGE frames. The receiver is supposed to respond to each PATH_CHALLENGE frame with a PATH_RESPONSE frame. The attacker can prevent the receiver from sending out (the vast majority of) these PATH_RESPONSE frames by collapsing the peers congestion window (by selectively acknowledging received packets) and by manipulating the peer's RTT estimate. This vulnerability has been patched in versions 0.37.7, 0.38.2 and 0.39.4.

Affected products

VendorProductAffectedFixed
quic-go quic-go = 0.40.0, >= 0.39.0, < 0.39.4, >= 0.38.0, < 0.38.2, < 0.37.7 —

Fixed in Linux distributions

Distributions backport fixes, so the version that fixes this vulnerability differs per release — upgrade to at least the version shown. From the distributions' security trackers and advisories.

ReleasePackageFixed inAdvisory
Debian 14 golang-github-lucas-clemente-quic-go 0.38.2-1 —
Debian 13 golang-github-lucas-clemente-quic-go 0.38.2-1 —
Debian 12 golang-github-lucas-clemente-quic-go No fix yet —
ReleasePackageFixed inAdvisory
Ubuntu 26.10 golang-github-lucas-clemente-quic-go No fix yet —
Ubuntu 26.04 LTS golang-github-lucas-clemente-quic-go No fix yet —
Ubuntu 25.10 golang-github-lucas-clemente-quic-go No fix yet —
Ubuntu 24.04 LTS golang-github-lucas-clemente-quic-go No fix yet —
Ubuntu 22.04 LTS golang-github-lucas-clemente-quic-go No fix yet —
ReleasePackageFixed inAdvisory
Red Hat Ansible Automation Platform Inside 2 receptor 1.4.4-1.el8ap RHSA-2024:0855
Red Hat Ansible Automation Platform Developer 2 receptor 1.4.4-1.el8ap RHSA-2024:0855
Red Hat Ansible Automation Platform 2 receptor 1.4.4-1.el8ap RHSA-2024:0855
ReleasePackageFixed inAdvisory
openSUSE Tumbleweed kubo 0.32.1-1.1 openSUSE-SU-2025:14626-1
openSUSE Leap 16.0 dnscrypt-proxy 2.1.16-bp160.1.1 openSUSE-RU-2026:21160-1

Azure Linux

ReleasePackageFixed inAdvisory
Azure Linux 3 coredns 1.11.1-2 —
Azure Linux 2 (CBL-Mariner) coredns 1.11.1-5 —

Wolfi

ReleasePackageFixed inAdvisory
Wolfi rolling caddy +2 2.7.6-r2 —
Wolfi rolling frp 0.53.2-r1 —

Affected packages

EcosystemPackageAffectedFixedRecord
Go github.com/quic-go/quic-go >= 0.40.0, < 0.40.1 0.40.1 GHSA-ppxx-5m9h-6vxf
Go github.com/quic-go/quic-go >= 0.39.0, < 0.39.4 0.39.4 GHSA-ppxx-5m9h-6vxf
Go github.com/quic-go/quic-go >= 0.38.0, < 0.38.2 0.38.2 GHSA-ppxx-5m9h-6vxf
Go github.com/quic-go/quic-go < 0.37.7 0.37.7 GHSA-ppxx-5m9h-6vxf
Go github.com/quic-go/quic-go < 0.37.7 · >= 0.38.0, < 0.38.2 · >= 0.39.0, < 0.39.4 · >= 0.40.0, < 0.40.1 0.37.7, 0.38.2, 0.39.4, 0.40.1 GO-2024-2459

Advisories 4

References