Fixed packages 10
| Release | Package | Fixed in |
|---|---|---|
| Red Hat · RHEL 9 enterprise_linux:9::appstream | openssl-debuginfo | 1:3.5.5-4.el9_8 |
| Red Hat · RHEL 9 enterprise_linux:9::appstream | openssl-debugsource | 1:3.5.5-4.el9_8 |
| Red Hat · RHEL 9 enterprise_linux:9::appstream | openssl-devel | 1:3.5.5-4.el9_8 |
| Red Hat · RHEL 9 enterprise_linux:9::appstream | openssl-libs-debuginfo | 1:3.5.5-4.el9_8 |
| Red Hat · RHEL 9 enterprise_linux:9::appstream | openssl-perl | 1:3.5.5-4.el9_8 |
| Red Hat · RHEL 9 enterprise_linux:9::baseos | openssl | 1:3.5.5-4.el9_8 |
| Red Hat · RHEL 9 enterprise_linux:9::baseos | openssl-debuginfo | 1:3.5.5-4.el9_8 |
| Red Hat · RHEL 9 enterprise_linux:9::baseos | openssl-debugsource | 1:3.5.5-4.el9_8 |
| Red Hat · RHEL 9 enterprise_linux:9::baseos | openssl-libs | 1:3.5.5-4.el9_8 |
| Red Hat · RHEL 9 enterprise_linux:9::baseos | openssl-libs-debuginfo | 1:3.5.5-4.el9_8 |
Vulnerabilities 15
-
Critical 9.1
CMS AuthEnvelopedData Processing May Accept Forged Messages
Issue Summary: Cryptographic Message Services (CMS) processing fails to perform sufficient input validation on the cipher and tag length fields of AuthEnvelopedData containers, leading to various potential compromises. Impact Summary: Attackers making use of …
-
High 8.8CVE-2026-45447 Public exploit
Heap Use-After-Free in the PKCS7_verify() Function
Issue summary: A specially crafted PKCS#7 or S/MIME signed message could trigger a use-after-free during PKCS#7 signature verification. Impact summary: A use-after-free may result in process crashes, heap corruption, or potentially remote code execution. When…
-
High 8.1
Possible Heap Buffer Overflow in ASN.1 Multibyte String Conversion
Issue summary: A signed integer overflow when sizing the destination buffer for Unicode output in ASN1_mbstring_ncopy() can lead to a heap buffer overflow. Impact summary: A heap buffer overflow may lead to a crash or possibly attacker controlled code executi…
-
High 7.5
Heap Buffer Over-read in ASN.1 Content Parsing
Issue summary: Parsing a crafted DER-encoded ASN.1 structure with a primitive element whose content exceeds 2 gigabytes in length may cause a heap buffer over-read on 64-bit Unix and Unix-like platforms. Impact summary: The heap buffer over-read may crash the…
-
High 7.5
Unbounded Memory Growth in the QUIC PATH_CHALLENGE Handler
Issue summary: Remote peer may exhaust heap memory of the QUIC server or client by flooding it with packets containing PATH_CHALLENGE frames. Impact summary: A malicious remote peer can cause an unbounded memory allocation which can lead to an abnormal termin…
-
High 7.5
NULL Pointer Dereference in QUIC Server Initial Packet Handling
Issue summary: Receiving a QUIC initial packet with an invalid token may trigger a NULL pointer dereference in the OpenSSL QUIC server with address validation disabled. Impact summary: NULL pointer dereference typically causes abnormal termination of the affe…
-
High 7.5
AES-OCB IV Ignored on EVP_Cipher() Path
Issue summary: When an application drives an AES-OCB context through the public EVP_Cipher() one-shot interface, the application-supplied initialisation vector (IV) is silently discarded. Impact summary: Every message encrypted under the same key uses the sam…
-
High 7.5
Out-of-Bounds Read in CMS Password-Based Decryption
Issue summary: When CMS password-based decryption (RFC 3211 / PWRI key unwrap) processes attacker-supplied CMS data, an attacker-chosen stream-mode KEK cipher can trigger a heap out-of-bounds read in kek_unwrap_key(). Impact summary: A heap buffer over-read m…
-
High 7.4
PKCS#12 Files with PBMAC1 Are Accepted with Short HMAC Keys
Issue Summary: The PKCS#12 file processing fails to perform sufficient input validation for files that use Password-Based Message Authentication Code 1 (PBMAC1) integrity mechanism allowing a certificate and private key forgery. Impact Summary: An attacker im…
-
Medium 5.9
Possible NULL Dereference in Password-Based CMS Decryption
Issue summary: A specially crafted password-encrypted CMS message can trigger a NULL pointer dereference during CMS decryption. Impact summary: This NULL pointer dereference leads to an application crash and a Denial of Service. The CMS PasswordRecipientInfo.…
-
Medium 5.9
NULL Pointer Dereference in CRMF EncryptedValue Decryption
Issue summary: An attacker-controlled CMP (Certificate Management Protocol) server could trigger a NULL pointer dereference in a CMP client application. Impact summary: A NULL pointer dereference causes a crash of the application and a Denial of Service. An a…
-
Medium 5.3
Trust-Anchor Substitution via cert/issuer Typo in CMP rootCaKeyUpdate
Issue Summary: An error in the callback used to verify the certificate provided in a Root CA key update Certificate Management Protocol (CMP) message response rendered the certificate validation ineffectual, which could lead to escalation of credentials from …
-
Medium 4.8
Incorrect Tag Processing for Empty Messages in AES-GCM-SIV and AES-SIV modes
Issue summary: The implementations of AES-SIV (RFC 5297) and AES-GCM-SIV (RFC 8452) mishandle the authentication of AAD (Additional Authenticated Data) with an empty ciphertext allowing a forgery of such messages. Impact summary: An attacker can forge empty m…
-
Low 3.7
Multi-RecipientInfo Bleichenbacher Oracle in CMS_decrypt() and PKCS7_decrypt()
Issue summary: The CMS_decrypt and PKCS7_decrypt functions are vulnerable to Bleichenbacher-style attack when an attacker is able to provide the CMS or S/MIME messages and observe the error code and/or decryption output. Impact summary: The Bleichenbacher-sty…
-
Low 3.7
FFC-DH Peer Validation Uses Attacker-Supplied q
Issue summary: When EVP_PKEY_derive_set_peer() is called with a DHX (X9.42) peer key, the peer key is not properly checked for the subgroup membership. Impact summary: A malicious peer which presents an X9.42 key carrying the victim's p and g parameters, a fo…
References
-
article
https://access.redhat.com/security/updates/classification/#important
-
report
https://bugzilla.redhat.com/show_bug.cgi?id=2481879
-
report
https://bugzilla.redhat.com/show_bug.cgi?id=2481880
-
report
https://bugzilla.redhat.com/show_bug.cgi?id=2481881
-
report
https://bugzilla.redhat.com/show_bug.cgi?id=2481882
-
report
https://bugzilla.redhat.com/show_bug.cgi?id=2481884
-
report
https://bugzilla.redhat.com/show_bug.cgi?id=2481885
-
report
https://bugzilla.redhat.com/show_bug.cgi?id=2481887
-
report
https://bugzilla.redhat.com/show_bug.cgi?id=2481890
-
report
https://bugzilla.redhat.com/show_bug.cgi?id=2481891
-
report
https://bugzilla.redhat.com/show_bug.cgi?id=2481892
-
report
https://bugzilla.redhat.com/show_bug.cgi?id=2481893
-
report
https://bugzilla.redhat.com/show_bug.cgi?id=2481894
-
report
https://bugzilla.redhat.com/show_bug.cgi?id=2481896
-
report
https://bugzilla.redhat.com/show_bug.cgi?id=2481897
-
report
https://bugzilla.redhat.com/show_bug.cgi?id=2481898
-
advisory
https://security.access.redhat.com/data/csaf/v2/advisories/2026/rhsa-2026_25239.json
-
report
https://access.redhat.com/security/cve/CVE-2026-7383
-
advisory
https://www.cve.org/CVERecord?id=CVE-2026-7383
-
advisory
https://nvd.nist.gov/vuln/detail/CVE-2026-7383
-
report
https://access.redhat.com/security/cve/CVE-2026-9076
-
advisory
https://www.cve.org/CVERecord?id=CVE-2026-9076
-
advisory
https://nvd.nist.gov/vuln/detail/CVE-2026-9076
-
report
https://access.redhat.com/security/cve/CVE-2026-34180
-
advisory
https://www.cve.org/CVERecord?id=CVE-2026-34180
-
advisory
https://nvd.nist.gov/vuln/detail/CVE-2026-34180
-
report
https://access.redhat.com/security/cve/CVE-2026-34181
-
advisory
https://www.cve.org/CVERecord?id=CVE-2026-34181
-
advisory
https://nvd.nist.gov/vuln/detail/CVE-2026-34181
-
report
https://access.redhat.com/security/cve/CVE-2026-34182
-
advisory
https://www.cve.org/CVERecord?id=CVE-2026-34182
-
advisory
https://nvd.nist.gov/vuln/detail/CVE-2026-34182
-
report
https://access.redhat.com/security/cve/CVE-2026-34183
-
advisory
https://www.cve.org/CVERecord?id=CVE-2026-34183
-
advisory
https://nvd.nist.gov/vuln/detail/CVE-2026-34183
-
report
https://access.redhat.com/security/cve/CVE-2026-42764
-
advisory
https://www.cve.org/CVERecord?id=CVE-2026-42764
-
advisory
https://nvd.nist.gov/vuln/detail/CVE-2026-42764
-
report
https://access.redhat.com/security/cve/CVE-2026-42766