Skip to content
OpenAdvisories
High USN-6633-1 5 CVEs

bind9 vulnerabilities

Published Feb 13, 2024 · Updated Apr 27, 2026

Summary

Shoham Danino, Anat Bremler-Barr, Yehuda Afek, and Yuval Shavitt discovered
that Bind incorrectly handled parsing large DNS messages. A remote attacker
could possibly use this issue to cause Bind to consume resources, leading
to a denial of service. (CVE-2023-4408)

Elias Heftrig, Haya Schulmann, Niklas Vogel, and Michael Waidner discovered
that Bind icorrectly handled validating DNSSEC messages. A remote attacker
could possibly use this issue to cause Bind to consume resources, leading
to a denial of service. (CVE-2023-50387)

It was discovered that Bind incorrectly handled preparing an NSEC3 closest
encloser proof. A remote attacker could possibly use this issue to cause
Bind to consume resources, leading to a denial of service. (CVE-2023-50868)

It was discovered that Bind incorrectly handled reverse zone queries when
nxdomain-redirect is enabled. A remote attacker could possibly use this
issue to cause Bind to crash, leading to a denial of service.
(CVE-2023-5517)

It was discovered that Bind incorrectly handled recursive resolution when
both DNS64 and serve-stable were enabled. A remote attacker could possibly
use this issue to cause Bind to crash, leading to a denial of service.
(CVE-2023-5679)

Fixed packages 1

ReleasePackageFixed in
Ubuntu · 22.04 LTS 22.04:LTS bind9 1:9.18.18-0ubuntu0.22.04.2

Vulnerabilities 5

  • High 7.5

    Parsing large DNS messages may cause excessive CPU load

    The DNS message parsing code in `named` includes a section whose computational complexity is overly high. It does not cause problems for typical DNS traffic, but crafted queries and responses may cause excessive CPU load on the affected `named` instance by ex…

  • High 7.5
    CVE-2023-50387 Public exploit EPSS 100%

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to …

  • High 7.5
    CVE-2023-50868 Public exploit EPSS 74%

    The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote att…

  • High 7.5

    Querying RFC 1918 reverse zones may cause an assertion failure when "nxdomain-redirect" is enabled

    A flaw in query-handling code can cause `named` to exit prematurely with an assertion failure when: - `nxdomain-redirect <domain>;` is configured, and - the resolver receives a PTR query for an RFC 1918 address that would normally result in an authoritative N…

  • High 7.5

    Enabling both DNS64 and serve-stale may cause an assertion failure during recursive resolution

    A bad interaction between DNS64 and serve-stale may cause `named` to crash with an assertion failure during recursive resolution, when both of these features are enabled. This issue affects BIND 9 versions 9.16.12 through 9.16.45, 9.18.0 through 9.18.21, 9.19…

References

  • report
    https://ubuntu.com/security/CVE-2023-4408
  • report
    https://ubuntu.com/security/CVE-2023-5517
  • report
    https://ubuntu.com/security/CVE-2023-5679
  • report
    https://ubuntu.com/security/CVE-2023-50387
  • report
    https://ubuntu.com/security/CVE-2023-50868