Summary
Elias Heftrig, Haya Schulmann, Niklas Vogel, and Michael Waidner discovered
that Bind icorrectly handled validating DNSSEC messages. A remote attacker
could possibly use this issue to cause Bind to consume resources, leading
to a denial of service. (CVE-2023-50387)
It was discovered that Bind incorrectly handled preparing an NSEC3 closest
encloser proof. A remote attacker could possibly use this issue to cause
Bind to consume resources, leading to a denial of service. (CVE-2023-50868)
Fixed packages 3
| Release | Package | Fixed in |
|---|---|---|
| Ubuntu · Pro 14.04 LTS Pro:14.04:LTS | bind9 | 1:9.9.5.dfsg-3ubuntu0.19+esm12 |
| Ubuntu · Pro 16.04 LTS Pro:16.04:LTS | bind9 | 1:9.10.3.dfsg.P4-8ubuntu1.19+esm8 |
| Ubuntu · Pro 18.04 LTS Pro:18.04:LTS | bind9 | 1:9.11.3+dfsg-1ubuntu1.19+esm3 |
Vulnerabilities 2
-
High 7.5
Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to …
-
High 7.5
The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote att…