Skip to content
OpenAdvisories

Summary

Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in Internet Systems Consortium BIND ausnutzen, um einen Denial of Service Angriff durchzuführen.

Product

BIND (Berkeley Internet Name Domain) ist ein Open-Source-Softwarepaket, das einen Domain-Name-System-Server implementiert.

Vulnerabilities 7

  • High 7.5

    Parsing large DNS messages may cause excessive CPU load

    The DNS message parsing code in `named` includes a section whose computational complexity is overly high. It does not cause problems for typical DNS traffic, but crafted queries and responses may cause excessive CPU load on the affected `named` instance by ex…

  • High 7.5
    CVE-2023-50387 Public exploit EPSS 100%

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to …

  • High 7.5
    CVE-2023-50868 Public exploit EPSS 74%

    The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote att…

  • High 7.5

    Querying RFC 1918 reverse zones may cause an assertion failure when "nxdomain-redirect" is enabled

    A flaw in query-handling code can cause `named` to exit prematurely with an assertion failure when: - `nxdomain-redirect <domain>;` is configured, and - the resolver receives a PTR query for an RFC 1918 address that would normally result in an authoritative N…

  • High 7.5

    Enabling both DNS64 and serve-stale may cause an assertion failure during recursive resolution

    A bad interaction between DNS64 and serve-stale may cause `named` to crash with an assertion failure during recursive resolution, when both of these features are enabled. This issue affects BIND 9 versions 9.16.12 through 9.16.45, 9.18.0 through 9.18.21, 9.19…

  • High 7.5

    Specific recursive query patterns may lead to an out-of-memory condition

    To keep its cache database efficient, `named` running as a recursive resolver occasionally attempts to clean up the database. It uses several methods, including some that are asynchronous: a small chunk of memory pointing to the cache element that can be clea…

  • Medium 5.3

    Cleaning an ECS-enabled cache may cause excessive CPU load

    If a resolver cache has a very large number of ECS records stored for the same name, the process of cleaning the cache database node for this name can significantly impair query performance. This issue affects BIND 9 versions 9.11.3-S1 through 9.11.37-S1, 9.1…

Revision history

  1. #68

    Neue Updates von Oracle Linux aufgenommen

  2. #67

    Neue Updates von NetApp aufgenommen

  3. #66

    Neue Updates von Oracle Linux aufgenommen

  4. #65

    Neue Updates von NetApp aufgenommen

  5. #64

    Neue Updates von SUSE aufgenommen

  6. #63

    Neue Updates aufgenommen

  7. #62

    Neue Updates von Amazon aufgenommen

  8. #61

    Neue Updates von IBM aufgenommen

  9. #60

    Neue Updates von Oracle Linux aufgenommen

  10. #59

    Neue Updates von SUSE aufgenommen

  11. #58

    Neue Updates von SUSE aufgenommen

  12. #57

    Neue Updates von Juniper aufgenommen

  13. #56

    Neue Updates von Red Hat aufgenommen

  14. #55

    Neue Updates von Oracle Linux aufgenommen

  15. #54

    Neue Updates von Red Hat aufgenommen

  16. #53

    Neue Updates von Gentoo aufgenommen

  17. #52

    Neue Updates von Debian aufgenommen

  18. #51

    Neue Updates von XEROX aufgenommen

  19. #50

    Neue Updates von Dell aufgenommen

  20. #49

    Neue Updates von Debian aufgenommen

  21. #48

    Neue Updates von Amazon aufgenommen

  22. #47

    Neue Updates von Oracle Linux aufgenommen

  23. #46

    Neue Updates von Oracle Linux aufgenommen

  24. #45

    Neue Updates von Dell aufgenommen

  25. #44

    Neue Updates von SUSE aufgenommen

References