Skip to content
OpenAdvisories

Package · Packagist

cakephp/cakephp

22 known vulnerabilities.

22 results · Feed

  • Low 3.7

    CakePHP through 5.4.3 Email Header Injection via Bare CR/LF in SmtpTransport and MailTransport

    CakePHP 4.5.12, 4.6.5, 5.1.8 through 5.1.10, 5.2.14 through 5.2.15, 5.3.7, and 5.4.0 through 5.4.3 contain an email header injection vulnerability because SmtpTransport and MailTransport strip only CRLF pairs from header values, an incomplete fix for CVE-2026…

  • Critical 9.2
    CVE-2026-79752 Public exploit

    CakePHP: Multiple methods in FunctionsBuilder vulnerable to SQL injection

    CakePHP is a rapid development framework for PHP. Prior to 4.5.12, 4.6.5, 5.1.9, 5.2.14, and 5.3.7, FunctionsBuilder::cast, FunctionsBuilder::extract, FunctionsBuilder::datePart, and FunctionsBuilder::dateAdd in src/Database/FunctionsBuilder.php accept user-c…

  • Critical 9.2
    CVE-2026-77635 Public exploit

    CakePHP: FunctionsBuilder::jsonValue() vulerable to SQL injection with PostgresDriver

    CakePHP is a rapid development framework for PHP. Prior to versions 5.1.10, 5.2.15, and 5.3.7 on their respective release lines, FunctionsBuilder::jsonValue() with PostgresDriver is vulnerable to SQL injection when user-controlled data is supplied to the json…

  • Medium 6.3

    CakePHP: View::element() is missing a path containment check

    CakePHP is a rapid development framework for PHP. In versions 4.5.11 and earlier, 4.6.0 through 4.6.3, 5.0.0 through 5.1.6, 5.2.0 through 5.2.12, and 5.3.0 through 5.3.5, View::_getElementFileName() does not check that the resolved element path is within the …

  • Medium 5.4

    CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting

    CakePHP is a rapid development framework for PHP. The PaginatorHelper::limitControl() method has a cross-site-scripting vulnerability via query string parameter manipulation. This issue has been fixed in 5.2.12 and 5.3.1.

  • Medium —

    CakePHP vulnerable to Cross-site Scripting in some development error pages

    CakePHP 3.4 prior to 3.4.14, 3.5 prior to 3.5.17, and 3.6 prior to 3.6.4 contains a cross-site-scripting (XSS) vulnerability in the development only `missing route` and `duplicate named route` error pages.

  • Medium —

    CakePHP vulnerable to Remote File Inclusion through View template name manipulation

    CakePHP 2.x prior to 2.0.99, 2.1.99, 2.2.99, 2.3.99, 2.4.99, 2.5.99, 2.6.12, and 2.7.6 and 3.x prior to 3.0.15 and 3.1.4 is vulnerable to Remote File Inclusion through View template name manipulation.

  • Medium —

    CakePHP allows direct access of prefixed controller actions

    Unconventional URL paths would allow direct access to prefixed actions without setting the correct request parameters.

  • High —

    CakePHP vulnerable to Denial of Service attack through XML payloads

    RequestHandlerComponent had a vulnerability that would allow well crafted requests to create a denial of service attack. RequestHandlerComponent leverages `Xml::build()` which allows reading local files. We recommend that all applications using RequestHandler…

  • Medium —

    CakePHP SecurityComponent cross form submission issue

    Prior to versions 2.4.8 and 1.3.18, forms secured by SecurityComponent could be submitted to any action without triggering SecurityComponent’s tampering protection. If an application contained multiple POST forms to manipulate the same models, it could be vul…

  • Medium —

    CakePHP has incorrect Cross-Site Request Forgery validation

    CsrfComponent fails to invalidate requests that are missing both the CSRF token, and CSRF post data.

  • Critical 9.8

    Database Query::offset() and limit() vulnerable to SQL injection in cakephp

    CakePHP is a development framework for PHP web apps. In affected versions the `Cake\Database\Query::limit()` and `Cake\Database\Query::offset()` methods are vulnerable to SQL injection if passed un-sanitized user request data. This issue has been fixed in 4.2…

  • High 8.8

    CakePHP allows method override parameters to bypass CSRF checks

    A vulnerability exists in CakePHP versions 4.0.x through 4.1.3. The CsrfProtectionMiddleware component allows method override parameters to bypass CSRF checks by changing the HTTP request method to an arbitrary string that is not in the list of request method…

  • Medium 4.3

    Cross-Site Request Forgery in CakePHP

    CakePHP before 4.0.6 mishandles CSRF token generation. This might be remotely exploitable in conjunction with XSS.

  • High 7.5

    Unsafe deserialization in SmtpTransport in CakePHP

    An issue was discovered in SmtpTransport in CakePHP 3.7.6. An unserialized object with modified internal properties can trigger arbitrary file overwriting upon destruction.

  • High 7.5
    CVE-2016-4793 Public exploit

    CakePHP allows remote attackers to spoof their IP

    The clientIp function in CakePHP 3.2.4 and earlier allows remote attackers to spoof their IP via the CLIENT-IP HTTP header.

  • High 8.8

    CakePHP might allow remote attackers to bypass CSRF protection mechanism via the _method parameter

    CakePHP 2.x and 3.x before 3.1.5 might allow remote attackers to bypass the CSRF protection mechanism via the _method parameter.

  • High 7.5
    CVE-2012-4399 Public exploit EPSS 12%

    CakePHPallows remote attackers to read arbitrary files via XML data containing external entity references

    The Xml class in CakePHP 2.1.x before 2.1.5 and 2.2.x before 2.2.1 allows remote attackers to read arbitrary files via XML data containing external entity references, aka an XML external entity (XXE) injection attack.

  • Medium —

    CakePHP 1.3.7 allows remote attackers to obtain sensitive information via a direct request to a .php file

    CakePHP 1.3.7 allows remote attackers to obtain sensitive information via a direct request to a .php file, which reveals the installation path in an error message, as demonstrated by dispatcher.php and certain other files.

  • High —
    CVE-2010-4335 Public exploit EPSS 55%

    CakePHP allows remote attackers to modify internal Cake cache and execute arbitrary code

    The _validatePost function in libs/controller/components/security.php in CakePHP 1.3.x through 1.3.5 and 1.2.8 allows remote attackers to modify the internal Cake cache and execute arbitrary code via a crafted data[_Token][fields] value that is processed by t…

  • Medium —
    CVE-2006-5031 Public exploit

    CakePHP directory traversal vulnerability allows remote attackers to read arbitrary files

    Directory traversal vulnerability in app/webroot/js/vendors.php in Cake Software Foundation CakePHP before 1.1.8.3544 allows remote attackers to read arbitrary files via a .. (dot dot) in the file parameter, followed by a filename ending with "%00" and a .js …

  • Medium 6.5

    Cross-site scripting (XSS) vulnerability in CakePHP

    Cross-site scripting (XSS) vulnerability in cake/libs/error.php in CakePHP before 1.1.7.3363 allows remote attackers to inject arbitrary web script or HTML via the URL, which is reflected back in a 404 ("Not Found") error page. NOTE: some of these details are…