Skip to content
OpenAdvisories

Package · Ubuntu

wordpress

171 known vulnerabilities.

31 results · Clear filters · Feed

  • High 8.1
    CVE-2026-87902 Exploited Public exploit EPSS 96%

    An unauthenticated attacker can make `get_page_template()` page-template resolution include a chosen readable local `.p…

    KEV Sep 25, 2026
  • High 7.1
    CVE-2026-93485 Public exploit

    WordPress Core <= 7.1 - Cross Site Scripting (XSS) vulnerability

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Automattic WordPress wordpress allows DOM-Based XSS.This issue affects WordPress: from n/a through 7.1.

  • High 8.8
    CVE-2026-65640 Public exploit

    WordPress is vulnerable to a remote code execution vulnerability via malicious Postscript file upload by an Author leve…

  • High 8.9
    CVE-2026-64638 Public exploit

    WordPress is vulnerable to a pre-auth reflected XSS vulnerability on the login screen. Via a specially crafted maliciou…

  • Critical 9.8
    CVE-2026-63030 Exploited Public exploit EPSS 11%

    WordPress < 7.0.2 - REST API batch-route confusion and SQL injection issue leading to Remote Code Execution

    WordPress 6.9.x before 6.9.5 and 7.0.x before 7.0.2 is affected by a REST API batch endpoint route confusion issue which, combined with the author__not_in WP_Query SQL Injection (CVE-2026-60137), could allow an attacker to perform SQL Injection and achieve Re…

    KEV Jul 21, 2026
  • Medium 5.9
    CVE-2026-60137 Exploited Public exploit

    WordPress < 7.0.2 - Facilitated SQL Injection via author__not_in in WP_Query

    WordPress 6.8.x before 6.8.6, 6.9.x before 6.9.5, and 7.0.x before 7.0.2 does not properly sanitise the author__not_in parameter of WP_Query, which could allow SQL Injection when a plugin or theme passes untrusted input to the parameter.

    KEV Jul 21, 2026
  • Low 3.7
    CVE-2025-54352 Public exploit

    WordPress 3.5 through 6.8.2 allows remote attackers to guess titles of private and draft posts via pingback.ping XML-RP…

  • High 7.2
    CVE-2024-4439 Public exploit EPSS 71%

    WordPress Core is vulnerable to Stored Cross-Site Scripting via user display names in the Avatar block in various versi…

  • Medium 5.5
    CVE-2024-31211 Public exploit

    Remote Code Execution in `WP_HTML_Token`

    WordPress is an open publishing platform for the Web. Unserialization of instances of the `WP_HTML_Token` class allows for code execution via its `__destruct()` magic method. This issue was fixed in WordPress 6.4.2 on December 6th, 2023. Versions prior to 6.4…

  • Medium 5.3
    CVE-2023-5561 Public exploit

    WordPress < 6.3.2 - Unauthenticated Post Author Email Disclosure

    WordPress does not properly restrict which user fields are searchable via the REST API, allowing unauthenticated attackers to discern the email addresses of users who have published public posts on an affected website via an Oracle style attack

  • Medium 5.4
    CVE-2023-2745 Public exploit EPSS 80%

    WordPress Core < 6.2.1 - Directory Traversal

    WordPress Core is vulnerable to Directory Traversal in versions up to, and including, 6.2, via the ‘wp_lang’ parameter. This allows unauthenticated attackers to access and load arbitrary translation files. In cases where an attacker is able to upload a crafte…

  • Medium 5.3
    CVE-2023-22622 Public exploit

    WordPress through 6.1.1 depends on unpredictable client visits to cause wp-cron.php execution and the resulting securit…

  • Medium 5.9
    CVE-2022-3590 Public exploit

    WP <= 6.1.1 - Unauthenticated Blind SSRF via DNS Rebinding

    WordPress is affected by an unauthenticated blind SSRF in the pingback feature. Because of a TOCTOU race condition between the validation checks and the HTTP request, attackers can reach internal hosts that are explicitly forbidden.

  • High 8.0
    CVE-2022-21661 Public exploit EPSS 98%

    SQL injection in WordPress

    WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database. Due to improper sanitization in WP_Query, there can be cases where SQL injection is possible through plugins or themes that use it in a certain wa…

  • High 7.1
    CVE-2021-29447 Public exploit EPSS 86%

    WordPress Authenticated XXE attack when installation is running PHP 8

    Wordpress is an open source CMS. A user with the ability to upload files (like an Author) can exploit an XML parsing issue in the Media Library leading to XXE attacks. This requires WordPress installation to be using PHP 8. Access to internal files is possibl…

  • Unscored —
    CVE-2020-28032 Public exploit EPSS 16%

    WordPress before 5.5.2 mishandles deserialization requests in wp-includes/Requests/Utility/FilteredIterator.php.

  • Medium 6.1
    CVE-2020-11027 Public exploit EPSS 14%

    Password reset links invalidation issue in WordPress

    In affected versions of WordPress, a password reset link emailed to a user does not expire upon changing the user password. Access would be needed to the email account of the user by a malicious party for successful execution. This has been patched in version…

  • Unscored —
    CVE-2019-17671 Public exploit EPSS 37%

    In WordPress before 5.2.4, unauthenticated viewing of certain content is possible because the static query property is …

  • Unscored —
    CVE-2019-16223 Public exploit

    WordPress before 5.2.3 allows XSS in post previews by authenticated users.

  • Unscored —
    CVE-2019-9787 Public exploit EPSS 39%

    WordPress before 5.1.1 does not properly filter comment content, leading to Remote Code Execution by unauthenticated us…

  • Unscored —
    CVE-2019-8942 Public exploit EPSS 83%

    WordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution because an _wp_attached_file Post Meta entry c…

  • Unscored —
    CVE-2019-8943 Public exploit EPSS 92%

    WordPress through 5.0.3 allows Path Traversal in wp_crop_image(). An attacker (who has privileges to crop an image) can…

  • Unscored —
    CVE-2018-20148 Public exploit EPSS 27%

    In WordPress before 4.9.9 and 5.x before 5.0.1, contributors could conduct PHP object injection attacks via crafted met…

  • Unscored —
    CVE-2018-12895 Public exploit EPSS 62%

    WordPress through 4.9.6 allows Author users to execute arbitrary code by leveraging directory traversal in the wp-admin…

  • Unscored —
    CVE-2018-6389 Public exploit EPSS 73%

    In WordPress through 4.9.2, unauthenticated attackers can cause a denial of service (resource consumption) by using the…

  • Unscored —
    CVE-2017-14719 Public exploit EPSS 12%

    Before version 4.8.2, WordPress was vulnerable to a directory traversal attack during unzip operations in the ZipArchiv…

  • Unscored —
    CVE-2017-8295 Public exploit EPSS 27%

    WordPress through 4.7.4 relies on the Host HTTP header for a password-reset e-mail message, which makes it easier for r…

  • Unscored —
    CVE-2016-6896 Public exploit EPSS 38%

    Directory traversal vulnerability in the wp_ajax_update_plugin function in wp-admin/includes/ajax-actions.php in WordPr…

  • Unscored —
    CVE-2016-6897 Public exploit EPSS 29%

    Cross-site request forgery (CSRF) vulnerability in the wp_ajax_update_plugin function in wp-admin/includes/ajax-actions…

  • Unscored —
    CVE-2014-5266 Public exploit EPSS 25%

    The Incutio XML-RPC (IXR) Library, as used in WordPress before 3.9.2 and Drupal 6.x before 6.33 and 7.x before 7.31, do…

  • Unscored —
    CVE-2013-7233 Public exploit

    Cross-site request forgery (CSRF) vulnerability in the retrospam component in wp-admin/options-discussion.php in WordPr…