Skip to content
OpenAdvisories

Weakness (CWE)

CWE-400: Uncontrolled Resource Consumption

Class Draft Mapping discouraged

The product does not properly control the allocation and maintenance of a limited resource.

How to prevent it (4 mitigations)
  1. Architecture and Design

    Design throttling mechanisms into the system architecture. The best protection is to limit the amount of resources that an unauthorized user can cause to be expended. A strong authentication and access control model will help prevent such attacks from occurring in the first place. The login application should be protected against DoS attacks as much as possible. Limiting the database access, perhaps by caching result sets, can help minimize the resources expended. To further limit the potential for a DoS attack, consider tracking the rate of requests received from users and blocking requests that exceed a defined rate threshold.

  2. Architecture and Design

    Mitigation of resource exhaustion attacks requires that the target system either:

    - recognizes the attack and denies that user further access for a given amount of time, or

    - uniformly throttles all requests in order to make it more difficult to consume resources more quickly than they can again be freed.

    The first of these solutions is an issue in itself though, since it may allow attackers to prevent the use of the system by a particular valid user. If the attacker impersonates the valid user, they may be able to prevent the user from accessing the server in question.

    The second solution is simply difficult to effectively institute -- and even when properly done, it does not provide a full solution. It simply makes the attack require more resources on the part of the attacker.

  3. Architecture and Design

    Ensure that protocols have specific limits of scale placed on them.

  4. Implementation

    Ensure that all failures in resource allocation place the system into a safe posture.

Source: MITRE CWE-400

4,059 results · Feed

  • Medium 4.3

    Insufficient control of custom field value sizes

    Discourse is a platform for community discussion. For fields that are client editable, limits on sizes are not imposed. This allows a malicious actor to cause a Discourse instance to use excessive disk space and also often excessive bandwidth. The issue is pa…

  • High 8.6

    Discourse vulnerable to unlimited mentioned users in message serializer

    Discourse is a platform for community discussion. The message serializer uses the full list of expanded chat mentions (@all and @here) which can lead to a very long array of users. This issue was patched in versions 3.1.4 and beta 3.2.0.beta5.

  • High 7.5

    CVE-2023-34061 – Gorouter route pruning

    Cloud Foundry routing release versions from v0.163.0 to v0.283.0 are vulnerable to a DOS attack. An unauthenticated attacker can use this vulnerability to force route pruning and therefore degrade the service availability of the Cloud Foundry deployment.

  • Medium 6.4

    quic-go's path validation mechanism can cause denial of service

    quic-go is an implementation of the QUIC protocol (RFC 9000, RFC 9001, RFC 9002) in Go. An attacker can cause its peer to run out of memory sending a large number of PATH_CHALLENGE frames. The receiver is supposed to respond to each PATH_CHALLENGE frame with …

  • Medium 4.8

    The issue was addressed with improved checks. This issue is fixed in iOS 17.2 and iPadOS 17.2. An attacker in a privile…

  • Medium 4.3

    SourceCodester Engineers Online Portal File Upload resource consumption

    A vulnerability was found in SourceCodester Engineers Online Portal 1.0. It has been classified as problematic. Affected is an unknown function of the component File Upload Handler. The manipulation leads to resource consumption. It is possible to launch the …

  • Medium 6.5

    Cri-o: pods are able to break out of resource confinement on cgroupv2

    A flaw was found in CRI-O that involves an experimental annotation leading to a container being unconfined. This may allow a pod to specify and get any amount of memory/cpu, circumventing the kubernetes scheduler and potentially resulting in a denial of servi…

  • Medium 6.8

    Microsoft Identity Denial of service vulnerability

    Microsoft Identity Denial of service vulnerability

  • High 7.5

    .NET Denial of Service Vulnerability

    .NET Denial of Service Vulnerability

  • Medium 4.3

    Denial of Service of an Investigation in Splunk Enterprise Security through Investigation attachments

    In Splunk Enterprise Security (ES) versions below 7.1.2, an attacker can use investigation attachments to perform a denial of service (DoS) to the Investigation. The attachment endpoint does not properly limit the size of the request which lets an attacker ca…

  • High 7.5

    XWiki Denial of Service attack through attachments

    XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. A user able to attach a file to a page can post a malformed TAR file by manipulating file modification times headers, which when parsed by Tika, could cau…

  • Medium 5.7

    Autel EVO NANO drone flight control firmware version 1.6.5 is vulnerable to denial of service (DoS).

  • Medium 4.9

    Possible deadlock in Linux kernel event handling

    Closing of an event channel in the Linux kernel can result in a deadlock. This happens when the close is being performed in parallel to an unrelated Xen console action and the handling of a Xen console interrupt in an unprivileged guest. The closing of an eve…

  • High 7.5

    encoded_id-rails Denial of Service Vulnerability

    encoded_id-rails versions before 1.0.0.beta2 are affected by an uncontrolled resource consumption vulnerability. A remote and unauthenticated attacker might cause a denial of service condition by sending an HTTP request with an extremely long "id" parameter.

  • High 7.5

    An issue was discovered in O-RAN Software Community ric-plt-e2mgr in the G-Release environment, allows remote attackers…

  • Medium 5.5

    Versions of the package libredwg before 0.12.5.6384 are vulnerable to Denial of Service (DoS) due to an out-of-bounds r…

  • High 7.5

    An issue was discovered in open5gs v2.6.6. SIGPIPE can be used to crash AMF.

  • Medium 5.9

    An issue was discovered in open5gs v2.6.6. InitialUEMessage, Registration request sent at a specific time can crash AMF…

  • Medium 5.5

    An issue in YASM 1.3.0.86.g9def allows a remote attacker to cause a denial of service via the yasm_section_bcs_first fu…

  • High 7.5

    An issue in Cesanta mjs 2.20.0 allows a remote attacker to cause a denial of service via the mjs+0x4ec508 component.

  • Medium 5.5

    An issue in YASM 1.3.0.86.g9def allows a remote attacker to cause a denial of service via the expand_smacro function in…

  • Medium 5.3

    jose2go vulnerable to denial of service via large p2c value

    The jose2go component before 1.6.0 for Go allows attackers to cause a denial of service (CPU consumption) via a large p2c (aka PBES2 Count) value.

  • Medium 6.5

    jose4j denial of service via specifically crafted JWE

    The jose4j component before 0.9.4 for Java allows attackers to cause a denial of service (CPU consumption) via a large p2c (aka PBES2 Count) value.

  • High 7.5

    Grackle has StackOverflowError in GraphQL query processing

    Grackle is a GraphQL server written in functional Scala, built on the Typelevel stack. The GraphQL specification requires that GraphQL fragments must not form cycles, either directly or indirectly. Prior to Grackle version 0.18.0, that requirement wasn't chec…

  • Medium 6.5

    Grails® data binding causes JVM crash and/or DoS

    Grails is a framework used to build web applications with the Groovy programming language. A specially crafted web request can lead to a JVM crash or denial of service. Any Grails framework application using Grails data binding is vulnerable. This issue has b…

  • High 7.5

    Sentry's Astro SDK vulnerable to ReDoS

    Sentry-Javascript is official Sentry SDKs for JavaScript. A ReDoS (Regular expression Denial of Service) vulnerability has been identified in Sentry's Astro SDK 7.78.0-7.86.0. Under certain conditions, this vulnerability allows an attacker to cause excessive …

  • Critical 9.6

    Uncontrolled Resource Consumption in EFACEC BCU 500

    Through the exploitation of active user sessions, an attacker could send custom requests to cause a denial-of-service condition on the device.

  • Medium 6.5

    Apache Superset: Allows for uncontrolled resource consumption via a ZIP bomb

    Uncontrolled resource consumption can be triggered by authenticated attacker that uploads a malicious ZIP to import database, dashboards or datasets.   This vulnerability exists in Apache Superset versions up to and including 2.1.2 and versions 3.0.0, 3.0.1.

  • High 7.5

    An uncaught exception issue discovered in Softing OPC UA C++ SDK before 6.30 for Windows operating system may cause the…

  • Medium 5.3

    Unbounded queuing of path validation messages in cloudflare-quiche

    quiche v. 0.15.0 through 0.19.0 was discovered to be vulnerable to unbounded queuing of path validation messages, which could lead to excessive resource consumption. QUIC path validation (RFC 9000 Section 8.2) requires that the recipient of a PATH_CHALLENGE f…

  • High 7.5

    Denial-of-service (DoS) vulnerability exists in commplex-link service of HMI GC-A2 series. If a remote unauthenticated …

  • Medium 4.3

    Todo plugin gets crashed and disabled by member

    Mattermost fails to handle a null request body in the /add endpoint, allowing a simple member to send a request with null request body to that endpoint and make it crash. After a few repetitions, the plugin is disabled. 

  • Medium 4.3

    Playbook Plugin Crash via Run Checklist

    Mattermost fails to to check the length when setting the title in a run checklist in Playbooks, allowing an attacker to send a specially crafted request and crash the Playbooks plugin

  • Low 2.2

    Postgresql: role pg_signal_backend can signal certain superuser processes.

    A flaw was found in PostgreSQL involving the pg_cancel_backend role that signals background workers, including the logical replication launcher, autovacuum workers, and the autovacuum launcher. Successful exploitation requires a non-core extension with a less…

  • High 7.5

    Denial of service by abusing `fetchOptions.retry` in nuxt-api-party

    `nuxt-api-party` is an open source module to proxy API requests. The library allows the user to send many options directly to `ofetch`. There is no filter on which options are available. We can abuse the retry logic to cause the server to crash from a stack o…

  • High 7.5

    Infinite decoding loop through specially crafted payload

    The Candid library causes a Denial of Service while parsing a specially crafted payload with 'empty' data type. For example, if the payload is `record { * ; empty }` and the canister interface expects `record { * }` then the Rust candid decoder treats empty a…

  • High 7.5

    Uncontrolled Resource Consumption in Metasys and Facility Explorer

    Under certain circumstances, invalid authentication credentials could be sent to the login endpoint of Johnson Controls Metasys NAE55, SNE, and SNC engines prior to versions 11.0.6 and 12.0.4 and Facility Explorer F4-SNC engines prior to versions 11.0.6 and 1…

  • Medium 5.3

    WordPress Ninja Forms Plugin <= 3.6.25 is vulnerable to Denial of Service Attack

    Uncontrolled Resource Consumption vulnerability in Saturday Drive Ninja Forms Contact Form – The Drag and Drop Form Builder for WordPress leading to DoS.This issue affects Ninja Forms Contact Form – The Drag and Drop Form Builder for WordPress: from n/a throu…

  • High 7.5

    A lack of rate limiting in pjActionAjaxSend in Car Rental v3.0 allows attackers to cause resource exhaustion.

  • Low —

    eventing-github vulnerable to denial of service caused by improper enforcement of the timeout on individual read operations

    ### Impact The eventing-github cluster-local server doesn't set `ReadHeaderTimeout`‬‭ which could lead do a DDoS‬ ‭attack, where a large group of users send requests to the server causing the server to hang‬ ‭for long enough to deny it from being available to…