Skip to content
OpenAdvisories

Package · Debian

bind9

159 known vulnerabilities.

16 results · Clear filters · Feed

  • High 8.1
    CVE-2026-94300 Public exploit

    Concurrent GSS-TSIG messages corrupt memory

    Replaying GSS-TSIG signed UDP messages can result in memory corruption in "`named`". An attacker who can capture a previously signed UDP message can replay it while the negotiated TSIG key is still valid. By also sending crafted queries to a zone the attacker…

  • Medium 5.3
    CVE-2026-5950 Public exploit

    Unbounded resend loop in BIND 9 resolver

    An unbounded resend loop vulnerability exists in the BIND 9 resolver state machine during bad-server handling, enabling a remote unauthenticated attacker to cause severe resource exhaustion by sending queries that trigger specific retry conditions. This issue…

  • High 8.6
    CVE-2025-40778 Public exploit

    Cache poisoning attacks with unsolicited RRs

    Under certain circumstances, BIND is too lenient when accepting records from answers, allowing an attacker to inject forged data into the cache. This issue affects BIND 9 versions 9.11.0 through 9.16.50, 9.18.0 through 9.18.39, 9.20.0 through 9.20.13, 9.21.0 …

  • High 7.5
    CVE-2025-40775 Public exploit EPSS 15%

    DNS message with invalid TSIG causes an assertion failure

    When an incoming DNS protocol message includes a Transaction Signature (TSIG), BIND always checks it. If the TSIG contains an invalid value in the algorithm field, BIND immediately aborts with an assertion failure. This issue affects BIND 9 versions 9.20.0 th…

  • High 7.5
    CVE-2024-0760 Public exploit

    A flood of DNS messages over TCP may make the server unstable

    A malicious client can send many DNS messages over TCP, potentially causing the server to become unstable while the attack is in progress. The server may recover after the attack ceases. Use of ACLs will not mitigate the attack. This issue affects BIND 9 vers…

  • High 7.5
    CVE-2023-50868 Public exploit EPSS 74%

    The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote att…

  • High 7.5
    CVE-2023-50387 Public exploit EPSS 100%

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to …

  • High 7.5
    CVE-2020-8617 Public exploit EPSS 93%

    A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c

    Using a specially-crafted message, an attacker may potentially cause a BIND server to reach an inconsistent state if the attacker knows (or successfully guesses) the name of a TSIG key used by the server. Since BIND, by default, configures a local session key…

  • High 7.5
    CVE-2018-5740 Public exploit EPSS 60%

    A flaw in the "deny-answer-aliases" feature can cause an assertion failure in named

    "deny-answer-aliases" is a little-used feature intended to help recursive server operators protect end users against DNS rebinding attacks, a potential method of circumventing the security model used by client browsers. However, a defect in this feature makes…

  • High 7.5
    CVE-2017-3143 Public exploit EPSS 18%

    An error in TSIG authentication can permit unauthorized dynamic updates

    An attacker who is able to send and receive messages to an authoritative DNS server and who has knowledge of a valid TSIG key name for the zone and service being targeted may be able to manipulate BIND into accepting an unauthorized dynamic update. Affects BI…

  • Unscored —
    CVE-2016-2776 Public exploit EPSS 89%

    buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x before 9.11.0rc3 does not properly…

  • High 7.5
    CVE-2015-5477 Exploited Public exploit EPSS 100%

    named in ISC BIND 9.x before 9.9.7-P2 and 9.10.x before 9.10.2-P3 allows remote attackers to cause a denial of service …

    KEV Oct 8, 2026
  • Unscored —
    CVE-2009-0696 Public exploit EPSS 13%

    The dns_db_findrdataset function in db.c in named in ISC BIND 9.4 before 9.4.3-P3, 9.5 before 9.5.1-P3, and 9.6 before …

  • Unscored —
    CVE-2008-1447 Public exploit EPSS 95%

    The DNS protocol, as implemented in (1) BIND 8 and 9 before 9.5.0-P1, 9.4.2-P1, and 9.3.5-P1; (2) Microsoft DNS in Wind…

  • Unscored —
    CVE-2007-2926 Public exploit EPSS 13%

    ISC BIND 9 through 9.5.0a5 uses a weak random number generator during generation of DNS query ids when answering resolv…

  • Unscored —
    CVE-2006-0987 Public exploit EPSS 58%

    The default configuration of ISC BIND before 9.4.1-P1, when configured as a caching name server, allows recursive queri…