8 results · Clear filters · Feed
-
High 8.1CVE-2026-66374 Public exploit
Knot Resolver before 6.4.1 allows remote code execution via a heap-based buffer overflow in the DoQ (DNS-over-QUIC) rec…
-
High 7.5
The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote att…
-
High 7.5
Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to …
-
High 7.5
Knot Resolver before 5.6.0 enables attackers to consume its resources, launching amplification attacks and potentially …
-
High 7.5
Knot Resolver before 5.5.3 allows remote attackers to cause a denial of service (CPU consumption) because of algorithmi…
-
High 7.5
Knot Resolver before 5.1.1 allows traffic amplification via a crafted DNS answer from an attacker-controlled server, ak…
-
High 7.5
knot-resolver before version 4.3.0 is vulnerable to denial of service through high CPU utilization. DNS replies with ve…
-
High 7.5CVE-2018-10920 Public exploit
Improper input validation bug in DNS resolver component of Knot Resolver before 2.4.1 allows remote attacker to poison …