15 results · Feed
-
High 8.1CVE-2026-66374 Public exploit
Knot Resolver before 6.4.1 allows remote code execution via a heap-based buffer overflow in the DoQ (DNS-over-QUIC) rec…
-
High 7.5
The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote att…
-
High 7.5
Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to …
-
Unscored —
Knot Resolver before 5.7.0 performs many TCP reconnections upon receiving certain nonsensical responses from servers.
-
High 7.5
Knot Resolver before 5.6.0 enables attackers to consume its resources, launching amplification attacks and potentially …
-
High 7.5
Knot Resolver before 5.5.3 allows remote attackers to cause a denial of service (CPU consumption) because of algorithmi…
-
Unscored —
Knot Resolver through 5.5.1 may allow DNS cache poisoning when there is an attempt to limit forwarding actions by filte…
-
Unscored —
Knot Resolver before 5.3.2 is prone to an assertion failure, triggerable by a remote attacker in an edge case (NSEC3 wi…
-
Unscored —
A flaw was found in knot-resolver before version 2.3.0. Malformed DNS messages may cause denial of service.
-
High 7.5
Knot Resolver before 5.1.1 allows traffic amplification via a crafted DNS answer from an attacker-controlled server, ak…
-
High 7.5
knot-resolver before version 4.3.0 is vulnerable to denial of service through high CPU utilization. DNS replies with ve…
-
Medium 6.3
A vulnerability was discovered in DNS resolver of knot resolver before version 4.1.0 which allows remote attackers to d…
-
Medium 5.4
A vulnerability was discovered in DNS resolver component of knot resolver through version 3.2.0 before 4.1.0 which allo…
-
High 7.5CVE-2018-10920 Public exploit
Improper input validation bug in DNS resolver component of Knot Resolver before 2.4.1 allows remote attacker to poison …
-
Unscored —
Improper input validation bugs in DNSSEC validators components in Knot Resolver (prior version 1.5.2) allow attacker in…