Skip to content
OpenAdvisories

Ecosystem

Pub

12 known vulnerabilities.

12 results · Feed

  • High 7.5

    Dio: Cross-origin redirect leaks sensitive request headers in `dio_http2_adapter`

    Dio is a powerful HTTP client for Dart and Flutter. From 1.0.0 until 2.8.0, dio_http2_adapter follows redirects in Http2Adapter._fetch by copying the original RequestOptions.headers into the redirected HTTP/2 request without comparing the source and destinati…

  • High 7.5

    jose vulnerable to untrusted JWK header key acceptance during signature verification

    JOSE is a Javascript Object Signing and Encryption (JOSE) library. Prior to version 0.3.5+1, a vulnerability in jose could allow an unauthenticated, remote attacker to forge valid JWS/JWT tokens by using a key embedded in the JOSE header (jwk). The vulnerabil…

  • Low 3.0

    shared_preferences_android vulnerability

    ### Impact Due to some data types not being natively representable for the available storage options, shared_preferences_android serializes and deserializes special string prefixes to store these unrepresentable data types. This allows arbitrary classes to be…

  • High 8.7

    Agent Dart missing certificate verification checks

    Agent Dart is an agent library built for Internet Computer for Dart and Flutter apps. Prior to version 1.0.0-dev.29, certificate verification in `lib/agent/certificate.dart` does not occur properly. During the delegation verification in the `_checkDelegation`…

  • High 7.4

    Serverpod client accepts any certificate

    Serverpod is an app and web server, built for the Flutter and Dart ecosystem. This bug bypassed the validation of TSL certificates on all none web HTTP clients in the `serverpod_client` package. Making them susceptible to a man in the middle attack against en…

  • Medium 5.3

    Improved security for stored password hashes

    Serverpod is an app and web server, built for the Flutter and Dart ecosystem. An issue was identified with the old password hash algorithm that made it susceptible to rainbow attacks if the database was compromised. This vulnerability is fixed by 1.2.6.

  • Medium 5.9

    pubnub Insufficient Entropy vulnerability

    Versions of the package pubnub before 7.4.0; all versions of the package com.pubnub:pubnub; versions of the package pubnub before 6.19.0; all versions of the package github.com/pubnub/go; versions of the package github.com/pubnub/go/v7 before 7.2.0; versions …

  • High 7.8

    Filename spoofing in archive

    An issue in Archive v3.3.7 allows attackers to spoof zip filenames which can lead to inconsistent filename parsing.

  • High 7.8

    Path traversal in Archive

    An issue in Archive v3.3.7 allows attackers to execute a path traversal via extracting a crafted zip file.

  • Medium 5.3

    personnummer/dart vulnerable to Improper Input Validation

    The personnummer implementation before 3.0.3 for Dart mishandles numbers in which the last four digits match the ^000[0-9]$ regular expression.

  • High 7.5

    dio vulnerable to CRLF injection with HTTP method string

    The dio package 4.0.0 for Dart allows CRLF injection if the attacker controls the HTTP method string, a different vulnerability than CVE-2020-35669.

  • Medium 6.1
    CVE-2020-35669 Public exploit

    http before 0.13.3 vulnerable to header injection

    An issue was discovered in the http package through 0.12.2 for Dart. If the attacker controls the HTTP method and the app is using Request directly, it's possible to achieve CRLF injection in an HTTP request.