63 results · Feed
-
Medium 4.7
systemd-machined: unprivileged users can terminate arbitrary processes
When systemd-machined >= v259 (or v258 with a custom `polkit` policy that allows `register-machine` access) is running on a desktop system, an unprivileged user logged in a desktop graphical session can kill arbitrary processes, even privileged ones. - versio…
-
Medium 6.7
systemd-homed: local privilege escalation via missing home-record signature verification on the authenticate path
systemd-homed contains a local privilege escalation bug via arbitrary system group addition to a local, logged in, homed-managed user
-
Medium 5.5
systemd-oomd: unprivileged users can terminate arbitrary processes
Local unprivileged users can terminate arbitrary local processes via a systemd-oomd IPC API due to a missing path traversal validation.
-
Low 2.9
In systemd 259, systemd-journald can send ANSI escape sequences to the terminals of arbitrary users when a "logger -p e…
-
Medium 6.2
In systemd 260 before 261, a local unprivileged user can trigger an assert via an IPC API call with an array or map tha…
-
Medium 6.4
In nspawn in systemd 233 through 259 before 260, an escape-to-host action can occur via a crafted optional config file.
-
Medium 6.4
In udev in systemd before 260, local root execution can occur via malicious hardware devices and unsanitized kernel out…
-
Medium 6.7
In systemd 259 before 260, there is local privilege escalation in systemd-machined because varlink can be used to reach…
-
Medium 4.7
In systemd 258 before 260, a local unprivileged user can trigger an assert when a Delegate=yes and User=<unset> unit ex…
-
Medium 5.5
systemd: Local unprivileged user can trigger an assert
systemd, a system and service manager, (as PID 1) hits an assert and freezes execution when an unprivileged IPC API call is made with spurious data. On version v249 and older the effect is not an assert, but stack overwriting, with the attacker controlled con…
-
Medium 6.7
Systemd: systemd: privilege escalation via improper access control in registermachine d-bus method
A flaw was found in systemd. The systemd-machined service contains an Improper Access Control vulnerability due to insufficient validation of the class parameter in the RegisterMachine D-Bus (Desktop Bus) method. A local unprivileged user can exploit this by …
-
Medium 4.7
Systemd-coredump: race condition that allows a local attacker to crash a suid program and gain read access to the resulting core dump
A vulnerability was found in systemd-coredump. This flaw allows an attacker to force a SUID process to crash and replace it with a non-SUID binary to access the original's privileged process coredump, allowing the attacker to read sensitive data, such as /etc…
-
High 7.5
The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote att…
-
High 7.5
Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to …
-
Medium 5.9
Systemd-resolved: unsigned name response in signed zone is not refused when dnssec=yes
A vulnerability was found in systemd-resolved. This issue may allow systemd-resolved to accept records of DNSSEC-signed domains even when they have no signature, allowing man-in-the-middles (or the upstream DNS resolver) to manipulate records.
-
Medium 5.3
An issue was discovered in systemd 253. An attacker can modify a sealed log file such that, in some views, not all exis…
-
Unscored —
An issue was discovered in systemd 253. An attacker can truncate a sealed log file and then resume log sealing such tha…
-
Unscored —
An issue was discovered in systemd 253. An attacker can modify the contents of past events in a sealed log file and the…
-
High 7.8
systemd before 247 does not adequately block local privilege escalation for some Sudo configurations, e.g., plausible s…
-
Medium 5.5
A vulnerability was found in systemd. This security flaw can cause a local information leak due to systemd-coredump not…
-
Medium 5.5
systemd 250 and 251 allows local users to achieve a systemd-coredump deadlock by triggering a crash that has a long bac…
-
Medium 5.5
An off-by-one Error issue was discovered in Systemd in format_timespan() function of time-util.c. An attacker could sup…
-
Unscored —
A use-after-free vulnerability was found in systemd. This issue occurs due to the on_stream_io() function and dns_strea…
-
Unscored —
A flaw was found in systemd. An uncontrolled recursion in systemd-tmpfiles may lead to a denial of service at boot time…
-
Medium 5.5
basic/unit-name.c in systemd prior to 246.15, 247.8, 248.5, and 249.1 has a Memory Allocation with an Excessive Size Va…
-
Medium 6.1
An exploitable denial-of-service vulnerability exists in Systemd 245. A specially crafted DHCP FORCERENEW packet can ca…
-
Medium 6.7
systemd through v245 mishandles numerical usernames such as ones composed of decimal digits or 0x followed by hex digit…
-
High 7.8CVE-2020-1712 Public exploit
A heap use-after-free vulnerability was found in systemd before version v245-rc1, where asynchronous Polkit queries are…
-
Unscored —
systemd 37-1 does not properly handle non-existent services, which causes a denial of service (failure of login procedu…
-
Medium 5.1
An issue was discovered in button_open in login/logind-button.c in systemd before 243. When executing the udevadm trigg…
-
Unscored —
systemd 239 through 245 accepts any certificate signed by a trusted certificate authority for DNS Over TLS. Server Name…
-
Unscored —
In systemd 240, bus_open_system_watch_bind_with_description in shared/bus-util.c (as used by systemd-resolved to connec…
-
Medium 4.5CVE-2019-3843 Public exploit
It was discovered that a systemd service that uses DynamicUser property can create a SUID/SGID binary that would be all…
-
Medium 4.5CVE-2019-3844 Public exploit
It was discovered that a systemd service that uses DynamicUser property can get new privileges through the execution of…
-
Medium 4.5CVE-2019-3842 Public exploit
In systemd before v242-rc4, it was discovered that pam_systemd does not properly sanitize the environment before using …
-
Unscored —
An issue was discovered in sd-bus in systemd 239. bus_process_object() in libsystemd/sd-bus/bus-objects.c allocates a v…
-
Medium 4.4
It was discovered systemd does not correctly check the content of PIDFile files before using it to kill processes. When…
-
High 7.5
An allocation of memory without limits, that could result in the stack clashing with another memory region, was discove…
-
High 7.4
An allocation of memory without limits, that could result in the stack clashing with another memory region, was discove…
-
Medium 4.3
An out of bounds read was discovered in systemd-journald in the way it parses log messages that terminate with a colon …